Closed Bug 12395 Opened 21 years ago Closed 20 years ago

[IME/rule]Crash-Typing Japanese characters in table causes Apprunner crashes

Categories

(Core :: Internationalization, defect, P2, major)

All
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 13786

People

(Reporter: teruko, Assigned: ftang)

Details

When you type Japanese characters in table, Apprunner crashes.

Steps of reproduce
1. Open Html Editor
2. Select menu Insert|Table
3. Click OK on Insert Table dialog to create a table on the top of the Editor
4. Turn on IME and type Japanese characters in the first colum
Apprunner crashes.

This does not happen if you type English.

I tested 8-20 Win32 and Mac builds.

Incident ID 12726253 (Windows)
 Trigger Type:  Program Crash
 Trigger Reason:  Access violation
 Call Stack:    (Signature = IMETextTxn::Do 4e810a77)

  IMETextTxn::Do                                              [d:\builds\seamonkey\mozilla\editor\base\IMETextTxn.cpp, line 80]
  nsTransactionItem::Do                                     [d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionItem.cpp, line
104]
  nsTransactionManager::BeginTransaction            [d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionManager.cpp,
line 1040]
  nsTransactionManager::Do                                [d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionManager.cpp,
line 137]
  nsEditor::Do                                                   [d:\builds\seamonkey\mozilla\editor\base\nsEditor.cpp, line 489]
  nsEditor::SetInputMethodText                           [d:\builds\seamonkey\mozilla\editor\base\nsEditor.cpp, line 3042]
  nsEditor::SetCompositionString                         [d:\builds\seamonkey\mozilla\editor\base\nsEditor.cpp, line 1317]
  nsTextEditorTextListener::HandleText                [d:\builds\seamonkey\mozilla\editor\base\nsEditorEventListeners.cpp, line
1038]
  nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line 723]
  nsDocument::HandleDOMEvent                         [d:\builds\seamonkey\mozilla\layout\base\src\nsDocument.cpp, line 2306]
  nsHTMLHtmlElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\layout\html\content\src\nsHTMLHtmlElement.cpp, line 188]
  PresShell::HandleEvent                                    [d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line
1869]
  nsView::HandleEvent                                       [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 835]
  nsView::HandleEvent                                       [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 820]
  nsView::HandleEvent                                       [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 820]
  nsView::HandleEvent                                       [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 820]
  nsViewManager::DispatchEvent                         [d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1611]
  HandleEvent                                                  [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 67]
  nsWindow::DispatchEvent                                 [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 502]
  nsWindow::DispatchWindowEvent                       [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 523]
  nsWindow::HandleTextEvent                             [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3635]
  nsWindow::ProcessMessage                             [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2855]
  nsWindow::WindowProc                                    [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 572]
  USER32.dll + 0x1186 (0x77e41186)
Priority: P3 → P2
Status: NEW → ASSIGNED
Target Milestone: M11
Assignee: tague → ftang
Status: ASSIGNED → NEW
Summary: Crash-Typing Japanese characters in table causes Apprunner crashes → [IME/rule]Crash-Typing Japanese characters in table causes Apprunner crashes
Target Milestone: M12 → M11
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 13786 ***
Status: RESOLVED → VERIFIED
This does not happen in 10-28-08 Win32 and Linux build.
You need to log in before you can comment on or make changes to this bug.