[IME/rule]Typing Japanese characters at the next line of Heading2 insert no text

VERIFIED DUPLICATE of bug 16570

Status

()

Core
Internationalization
P1
blocker
VERIFIED DUPLICATE of bug 16570
19 years ago
19 years ago

People

(Reporter: Teruko Kobayashi, Assigned: Frank Tang)

Tracking

Trunk
All
Windows NT
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
In the Editor, after you type Japaense characters as Heading2 and move to the next line to start type Japanese characters,
Apprunner will crash.

Steps of reproduce
1. Open the Editor
2. Turn on IME
3. Type Japanese characters in the first line (same line as "Here's the deal..")
4. Hit the return to move to next line
5. Start typing Japanese characters
Apprunner crashes.

Talkback Incident 13531736
Trigger Type:  Program Crash

 Trigger Reason:  Access violation

 Call Stack:    (Signature = IMETextTxn::Do 4e810a77)
     IMETextTxn::Do                                               [d:\builds\seamonkey\mozilla\editor\base\IMETextTxn.cpp, line 83]
     nsTransactionItem::Do                                      [d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionItem.cpp,
line 104]
     nsTransactionManager::BeginTransaction
[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionManager.cpp, line 1040]
     nsTransactionManager::Do
[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionManager.cpp, line 137]
     nsEditor::Do                                                    [d:\builds\seamonkey\mozilla\editor\base\nsEditor.cpp, line 343]
     nsEditor::SetInputMethodText                            [d:\builds\seamonkey\mozilla\editor\base\nsEditor.cpp, line 3060]
     nsEditor::SetCompositionString                          [d:\builds\seamonkey\mozilla\editor\base\nsEditor.cpp, line 1286]
     nsTextEditorTextListener::HandleText                 [d:\builds\seamonkey\mozilla\editor\base\nsEditorEventListeners.cpp,
line 1278]
     nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line 743]
     nsDocument::HandleDOMEvent                          [d:\builds\seamonkey\mozilla\layout\base\src\nsDocument.cpp, line
2322]
     nsHTMLHtmlElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\layout\html\content\src\nsHTMLHtmlElement.cpp, line 188]
     PresShell::HandleEvent                                     [d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line
1996]
     nsView::HandleEvent                                        [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 828]
     nsView::HandleEvent                                        [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 813]
     nsView::HandleEvent                                        [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 813]
     nsView::HandleEvent                                        [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 813]
     nsViewManager::DispatchEvent                          [d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1641]
     HandleEvent                                                   [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 63]
     nsWindow::DispatchEvent                                  [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 336]
     nsWindow::DispatchWindowEvent                        [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 353]
     nsWindow::HandleTextEvent                              [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line
3541]
     nsWindow::ProcessMessage                              [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line
2724]
     nsWindow::WindowProc                                    [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 402]
     USER32.dll + 0x1186 (0x77e41186)

This happens in Mac build also.
Tested 9-13 Win32 build and Mac build.
(Reporter)

Updated

19 years ago
Priority: P3 → P1

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Updated

19 years ago
Blocks: 14356

Updated

19 years ago
Blocks: 15693
(Assignee)

Updated

19 years ago
Assignee: tague → ftang
Status: ASSIGNED → NEW
(Assignee)

Comment 1

19 years ago
reassign to ftang per i18ngrp reassignment meeting.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Priority: P1 → P2
Summary: Crash-Start typing Japanese characters at the next line of Heading2 causes Apprunner crashes → [IME/rule] Crash-Start typing Japanese characters at the next line of Heading2 causes Apprunner crashes
(Assignee)

Comment 2

19 years ago
*** Bug 12395 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

19 years ago
*** Bug 12395 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

19 years ago
This is probably a dup of 15310. I will let this bug represent any crash of
IME/rule system problem in HTML Editor and let 15310 represent the one in text
widget.
(Assignee)

Comment 5

19 years ago
more info in IMETextTxn:Do() in break in line 83
  if (NS_SUCCEEDED(result) && selection) {
    if (mReplaceLength==0) {
->      result = mElement->InsertData(mOffset,mStringToInsert);
    } else {
      result = mElement->ReplaceData(mOffset,mReplaceLength,mStringToInsert);
    }

mElement.mRawPtr == 0
which cause it crash

Comment 6

19 years ago
right, you need to work with joe to figure out how to re-integrade IME into the
rule system.  you need to make sure that Textnodes/elements whatever you want to
call them are created when necessary and that the transactions still continue to
merge correctly for the IME transactions.

Updated

19 years ago
Blocks: 16127
(Assignee)

Comment 7

19 years ago
add jfrancis@netscape.com to cc.
(Assignee)

Updated

19 years ago
Severity: critical → blocker
Priority: P2 → P1
Summary: [IME/rule] Crash-Start typing Japanese characters at the next line of Heading2 causes Apprunner crashes → [IME/rule][IME-CRASH] Crash-Start typing Japanese characters at the next line of Heading2 causes Apprunner crashes
(Assignee)

Comment 8

19 years ago
*** Bug 12402 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Summary: [IME/rule][IME-CRASH] Crash-Start typing Japanese characters at the next line of Heading2 causes Apprunner crashes → [IME/rule]Typing Japanese characters at the next line of Heading2 insert no text
(Assignee)

Comment 9

19 years ago
I partially fix it so it now no longer crash, but assert. Continue will not
crash. But the problem is still there. Change the Summary from
"[IME/rule][IME-CRASH] Crash-Start typing Japanese characters at the next line
of Heading2 causes Apprunner crashes" to
"[IME/rule]Typing Japanese characters at the next line of Heading2 insert no
text"

I think the problem is in the RETURN Rule.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 10

19 years ago
*** This bug has been marked as a duplicate of 16570 ***

Updated

19 years ago
Blocks: 16950
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

19 years ago
This does not happen in 10-28-08 Win32 build.

Comment 12

19 years ago
this should be fixed on all platforms.
You need to log in before you can comment on or make changes to this bug.