[e10s] It's possible to accidentally get 2 visually selected tabs when opening tabs using window.open()

RESOLVED DUPLICATE of bug 1157404

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 1157404
3 years ago
3 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(e10s?, firefox46 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8707698 [details]
testcase 1 - [e10s] It's possible to get 2 visually selected tabs .html

>>>   My Info:   Win7_64, Nightly 46, 32bit, ID 20160112030227
STR:
1.   Open "testcase 1"
2.A) Click on the page content (white area)
2.B) Right-click on the page content
2.C) Middle-click on the page content
    *If you see a "blocked popup" message, please allow popups for the domain and repeat Steps 1-2

Result:       At least 2 new tabs open, and last 2 of them look selected
Expectations: Only one tab should look selected

Note:
 You may see bug 1235850 or bug 1239532 on attached "testcase 1". There's no need to file them.
(Reporter)

Updated

3 years ago
See Also: → bug 1235850, bug 1239532
I've seen this recently as well, working on other test cases.

Curious, why is the test case producing multiple tabs in e10s but only one new tab in non-e10s?
Flags: needinfo?(mconley)
The problem here is that visuallySelected can be updated in two places - one place is within our async tab switcher, and the other place is within moveTabTo, which is used to place newly opened tabs next to their "related" tab. When you open several new tabs so that they go through the moveTabTo codepath, you end up in a state where visuallySelected is set on the newly opened tab, and _then_ on the newly selected tab.

This should only ever occur if you open several new tabs simultaneously such that they open next to the tab you're on (ie, they were redirected from window.open calls).
Flags: needinfo?(mconley)
Jeff, do you think this should block?
Flags: needinfo?(jgriffiths)
Duping to bug 1157404. I'll transfer the needinfo there.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jgriffiths)
Resolution: --- → DUPLICATE
Duplicate of bug: 1157404
You need to log in before you can comment on or make changes to this bug.