If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Location bar is not updated when deleting search suggestion entries

REOPENED
Unassigned

Status

()

Firefox
Search
P3
normal
REOPENED
2 years ago
a year ago

People

(Reporter: petruta, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(firefox46 affected)

Details

(Whiteboard: [fxsearch] )

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Reproduced using Firefox 43.0.4, Firefox 44 beta 8, latest Aurora 45.0a2 and latest Nightly 46.0a1 2015-01-13 across platforms.

1. Open Firefox with a clean profile and start typing in the location bar
2. When asked, choose to see the search suggestions
3. Enter a term that offers search suggestions and go to the third entry from suggestions list - the url is filled with that suggestion
4. Delete that entry using the Delete key - the next entry is focused
5. Delete all suggestions

Actual results:
4. Url bar is not updated (still showing the deleted suggestion)
5. The entry that was selected the first time remains in the url bar, while the drop down only shows the first entry (entered term - Search with "default engine")

Expected results:
4. 5. The url bar is updated accordingly with the selected entries

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 669129

Comment 2

2 years ago
Oh, well, actually this looks more like dependant bug, because 669129 was reported
when there was no search suggestions available in location bar.
Status: RESOLVED → REOPENED
Depends on: 669129
Resolution: DUPLICATE → ---

Comment 3

2 years ago
can you test on latest nightly?  we've done some fixes in this area and can't duplicate on our systems.
Flags: needinfo?(petruta.rasa)
Whiteboard: [fxsearch]
(Reporter)

Comment 4

2 years ago
Created attachment 8731731 [details]
LocationBarDelete.gif

Reproduced with Nightly 48.0a1 2016-03-17 under Win 7 64-bit. I've attached a gif showing the issue.
Flags: needinfo?(petruta.rasa)
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.