Background-position does not work for input element on hover.

RESOLVED DUPLICATE of bug 1227327

Status

()

RESOLVED DUPLICATE of bug 1227327
3 years ago
2 years ago

People

(Reporter: travis, Assigned: mstange)

Tracking

({regression, testcase})

45 Branch
regression, testcase
Points:
---

Firefox Tracking Flags

(firefox44 unaffected, firefox45+ unaffected, firefox46+ unaffected, firefox47 unaffected, firefox48 fixed, firefox49 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8708105 [details]
firefoxbugtest.html

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160107004004

Steps to reproduce:

1) Set background to a url on an input element of type "submit".
2) Set background-position on input:hover.


Actual results:

Background does not change on mouse hover.

If manually setting the element state to :hover in dev tools, the background position only changes if you scroll it off the page.
The background position does change if you click the element.


Expected results:

The position of the background image should change.

The attached test has two inputs: one of type submit that exhibits the problem and one of type text that exhibits the expected behavior.

I was able to replicate the issue in Firefox Developer Edition (45.0a2) and Firefox Nightly (46.0a1) with a new profile but not Firefox 43.0.

jsfiddle matching the attached test: https://jsfiddle.net/1n59n4eo/5/

Comment 1

3 years ago
Works in Fx44b8, not works in 45.0a2 (2016-01-12) & 46.0a1 (2016-01-12).
Status: UNCONFIRMED → NEW
status-firefox44: --- → unaffected
status-firefox45: --- → affected
status-firefox46: --- → affected
Component: Untriaged → Layout
Ever confirmed: true
Keywords: regression, testcase
Product: Firefox → Core
Version: 46 Branch → 45 Branch

Comment 2

3 years ago
It seems there are two bug:
1: the button have focus will not get background while mouse out, but the background be restore when focus out.
2: the button lost the background when got focus, not be restore.
[Tracking Requested - why for this release]: Web-facing regression
tracking-firefox45: --- → ?
tracking-firefox46: --- → ?
Keywords: regressionwindow-wanted

Comment 4

3 years ago
Issue 1: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=097cac1912b9658ba68389b5dd72d4cc45e762d5&tochange=21cabf6ab3e9a254cdc9370986f300213b346cb2
Issue 2: Seems affected by my profile's prefs, reproducible in safemode, not reproducible in new profile.
Blocks: 1201327
Keywords: regressionwindow-wanted

Updated

3 years ago
Flags: needinfo?(mstange)
(Assignee)

Updated

3 years ago
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Flags: needinfo?(mstange)
Recent regression, tracking it.
tracking-firefox45: ? → +
tracking-firefox46: ? → +
(Assignee)

Updated

3 years ago
Depends on: 1244258
David, do you know who could help on this bug? Thanks
Flags: needinfo?(dbaron)
(In reply to Sylvestre Ledru [:sylvestre] from comment #6)
> David, do you know who could help on this bug? Thanks

Do we need more help on this one? The regression was backed out in bug 1244258. Bug 1201327 is where further work will happen.
Flags: needinfo?(dbaron) → needinfo?(sledru)
status-firefox45: affected → unaffected
tracking-firefox45: + → ---
OK, thanks for the information.
BTW, unaffected is enough to remove it from our radar (we keep the tracking because knowing that it has been tracked for 45 is an interesting information for us)
tracking-firefox45: --- → +
Flags: needinfo?(sledru)
(Assignee)

Comment 9

3 years ago
Bug 1201327 got backed out on 46, so this is now 46:unaffected.
status-firefox46: affected → unaffected
(Assignee)

Comment 10

2 years ago
I've backed out bug 1201327 on Aurora 47, so this bug is only present on Nightly now.
status-firefox47: --- → unaffected
status-firefox48: --- → affected
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1245356

Updated

2 years ago
Blocks: 1265954
(Assignee)

Comment 12

2 years ago
I've fixed this in bug 1227327, marking as a duplicate of that.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1227327
(Assignee)

Updated

2 years ago
No longer blocks: 1201327, 1265954
No longer depends on: 1244258
status-firefox48: affected → fixed
status-firefox49: --- → fixed
You need to log in before you can comment on or make changes to this bug.