Closed Bug 1240369 Opened 4 years ago Closed 4 years ago

detect initial and/or long blank audio stream as no audio, effect for audio indicator and mute button

Categories

(Core :: Audio/Video: Playback, enhancement)

44 Branch
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1235612

People

(Reporter: yfdyh000, Unassigned)

References

()

Details

+++ This bug was initially created as a clone of Bug #1190040 +++

Heard from bug 1231244 comment 34.

STR:
Open http://tinybuild.com/ and waiting the loaded.


The audio indicator shown, but there is no sound. Looks the some mp4 files have video without audio track, Firefox show the correctly when open it in Firefox, but the audio indicator looks not.
It's this MP4 file:
http://tinybuild.com/wp-content/uploads/2016/01/Punch-Club-Reel_optimized.mp4

They keep the audio stream but it's blank.
Good catch. So it has an audio stream, but no audio change, and currently Firefox can not to detect it. I hope that it is possible, if we can detect an blank audio stream. But perhaps this is unnecessary if sites should be allowed to do so intentionally or unintentionally.
Yes, I think the website did a bad choice, they should have uploaded a video stream without audio track, not just a blank audio track.
IMHO, Firefox behaves correctly here.
As an unconfirmed enhancement, if we have the development and user resources to implement it. It can be an optional feature (pref).
Severity: normal → enhancement
Status: NEW → UNCONFIRMED
Ever confirmed: false
Summary: tab audio-indicator still incorrectly shown for media without sound → detect initial and/or long blank audio stream as no audio, effect for audio indicator and mute button
It's what I want to implement in the bug1235612.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1235612
You need to log in before you can comment on or make changes to this bug.