Closed Bug 1231244 Opened 5 years ago Closed 5 years ago

Flash mute doesn't work with Flash Player 20 (Windows, Mac OSX)

Categories

(External Software Affecting Firefox :: Flash (Adobe), defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: yfdyh000, Unassigned)

References

Details

+++ This bug was initially created as a clone of Bug #1205477 +++

Adobe Flash Player NPAPI 20.0.0.235, the indicator not works too.
Ni ehsan
Flags: needinfo?(ehsan)
Is this the same as bug 1227221? I think this may be a duplicate, and Flash 20.0.0.238 may fix the issue.
Duplicate of this bug: 1231262
Duplicate of this bug: 1231310
Honestly I don't understand why the bug 1231244 has been closed, since it had more information. 

Anyway, Flash version 20.0.0.238 (currently beta) doesn't solve the problem.
Also see bug 1227221 comment #13 for this, they might have disabled it intentionally in Flash 20 to stop crashes and hangs in that release.
Depends on: 1227221
Looks like this is intentional on Adobe's side.  Clearing the needinfo for now.
Flags: needinfo?(ehsan)
¡Hola Ehsan!

Per http://www.adobe.com/software/flash/about/ Adobe has shipped 20.0.0.235 and this bug is hitting users.

A few reports in SUMO I've seen so far:

https://support.mozilla.org/en-US/questions/1098314
https://support.mozilla.org/en-US/questions/1098263

What's the plan now that this is affecting users?

¡Gracias!
Flags: needinfo?(ehsan)
See comment 6 please.
Flags: needinfo?(ehsan)
Duplicate of this bug: 1231851
Duplicate of this bug: 1231714
Is the Linux version of Flash (v11.2.202.554) affected too?
Duplicate of this bug: 1231589
Yes, the linux version of flash is affected.
Ubuntu 14.04.3 LTS
Firefox 42.0
Flash player 11,2,202,554
When viewing YouTube in html5 and Firefox, the audio button in the tab works like it should.
So Adobe is the culprit here.
Summary: Flash mute doesn't work with Flash Player 20 → Flash mute doesn't work with Flash Player 20 (Windows, Mac OSX) and 11.2 (Linux)
Wait. It's my understanding that Linux never had audio notification in Flash (v11 only getting security updates iiuc).

[Though I'm under the impression that those using the freshplayer wrapper (which utilizes Chrome's recent pepper Flash) are able to see the notifications.]

In which case there's probably no need to include Linux in this particular conversation.
(In reply to Caspy7 from comment #15)
> Wait. It's my understanding that Linux never had audio notification in Flash
> (v11 only getting security updates iiuc).

Exactly.
Let's keep this bug to the regression with Flash 20 compared to 19. Linux never had this working, so it's not a regression, and there are no plans to get it working on the old Flash version that Linux is bound to.
Summary: Flash mute doesn't work with Flash Player 20 (Windows, Mac OSX) and 11.2 (Linux) → Flash mute doesn't work with Flash Player 20 (Windows, Mac OSX)
Duplicate of this bug: 1232705
Duplicate of this bug: 1232564
I confirm this on OSS X 10.11.1 with Firefox 46.0a1 (2015-12-16) and Flash 20,0,0,235.
Duplicate of this bug: 1234968
Flash Player update 20.0.0.267 was released today 12-28-2015 and it looks like the mute issue is fixed.
The indicator shown and works with Flash Player 20.0.0.267 on Fx44.0b2 Win10. But it not disappear while video has paused and sound has stopped, unless the Flash element is disintegrated. I don't know whether it is an expected behavior.
The current behavior with HTML video has the audio indicator disappearing when a video is paused, so this is likely the intended behavior for Flash as well.

It sounds then that the feature is now partially broken for Flash.
The tab audio indicator (tab speaker button) now appears using Flash Player 20.0.0.267(Win7 Fx43) on tabs with http://video.foxnews.com Flash videos and works to mute and unmute sound. It did not appear after updating from Flash Player 19.x to Flash 20.0.0.235, as mentioned in the duplicate bug 1231310.  In that respect,the mute issue is "fixed" but I didn't consider what happens when pausing the video.

Using Flash Player 20.0.0.267, when you mute the audio from the Flash video itself, the tab audio indicator disappears but when you pause the video, it doesn't. With https://www.youtube.com/ HTML5 videos, the tab audio indicator disappears both when you pause the video and when you mute the audio.

Whether pausing a Flash video should cause the audio indicator to disappear from a tab, as it does with HTML5 videos, I don't know. Was it working in Flash Player 19?
I'm confused about what has specifically regressed in the new Flash builds.  Ryan, can we please get some QA to figure out the exact differences between Flash 19 and 20?  Thanks!  (The differences against HTML video doesn't matter.)
Flags: needinfo?(ryanvm)
Seems like a request better suited for Florin's verification team.
Flags: needinfo?(ryanvm) → needinfo?(florin.mezei)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #27)
> Seems like a request better suited for Florin's verification team.

Indeed the feature was tested by our team. Setting needinfo for Camelia and Cornel who worked on this.
Flags: needinfo?(florin.mezei)
Flags: needinfo?(cornel.ionce)
Flags: needinfo?(camelia.badau)
We tested the tab sound indicator with different Flash content websites on Windows 7 64bit and Mac OSX 10.9.5 using Firefox 43.0.3 (buildID: 20151223140742).
We've spotted several differences between Flash 19 and Flash 20, all of them related to the pause of the video (where the indicator remains displayed with latest Flash).

The detailed list of the differences and our testing results can be found here: https://public.etherpad-mozilla.org/p/Flash20-TabSoundIndicator
Flags: needinfo?(cornel.ionce)
Flags: needinfo?(camelia.badau)
Let me email my contact at Adobe to see if I can find out something about this.
This should be fixed in Flash 20.0.0.278.  Camelia, can you please re-test with the new version?
Flags: needinfo?(camelia.badau)
I've tested on Windows 7 64bit and Mac OSX 10.9.5 using Firefox 43.0.3 (buildID: 20151223140742) with latest Flash version 20.0.0.285 and the tab sound indicator works as expected except on this page: http://www.history2u.com/Volume_2_Sample_Clip.htm , where the sound indicator is still displayed when video is muted. Please see the testing results here: https://public.etherpad-mozilla.org/p/Flash20-TabSoundIndicator
Flags: needinfo?(camelia.badau)
OK, thanks for testing!  I forwarded this information to my Adobe contact.
With Adobe Flash Player beta 20.0.0.285 all good working, but on http://tinybuild.com/ Firefox show indicator. I do not hear anything on this page...
(In reply to mkdante381 from comment #34)
> With Adobe Flash Player beta 20.0.0.285 all good working, but on
> http://tinybuild.com/ Firefox show indicator. I do not hear anything on this
> page...

I filled bug 1240369.
We've tested on Windows 7 64bit, Windows 10 32bit and Mac OSX 10.8.5 using Firefox 45 Beta 3 (buildID: 20160204142810) and noticed that the issue from http://www.imdb.com/ page has recurred with Flash 20.0.0.286: sound indicator is still displayed when pausing the video.
We also saw the issue from comment 36 on the following page: http://www.dailymotion.com/video/x3qsu77_porsche-718-boxter-s-2017-footage-on-location-atmo-jan-2016_auto : sound indicator is still displayed when pausing the video. 

We've tested on Windows 7 64bit and Mac OSX 10.9.5 using Firefox 45 Beta 3 (buildID: 20160204142810) with latest Flash version 20.0.0.286 and Flash Player Beta 21.0.0.136 (both e10s on/off).
Flags: needinfo?(ehsan)
Component: General → Flash (Adobe)
Product: Firefox → Plugins
Version: 43 Branch → unspecified
I am going on vacation tomorrow, so won't have time to contact my Adobe contact.  Benoit and Andrea also have his contact.  Can one of you please email Eric about this?  Thanks!
Flags: needinfo?(ehsan)
Flags: needinfo?(bgirard)
Flags: needinfo?(amarchesini)
Sorry I was sick for a week and didn't get around to it :(
Flags: needinfo?(bgirard)
All is ok on Shockwave Flash 21.0.0.157 No bug with indicator on flash movies and bug with http://tinybuild.com/ is resolved
(In reply to mkdante381 from comment #40)
> All is ok on Shockwave Flash 21.0.0.157 No bug with indicator on flash
> movies and bug with http://tinybuild.com/ is resolved

Nope bug is on http://tinybuild.com/ This is mp4 (video?) file, not audio file.
(In reply to mkdante381 from comment #41)
> (In reply to mkdante381 from comment #40)
> > All is ok on Shockwave Flash 21.0.0.157 No bug with indicator on flash
> > movies and bug with http://tinybuild.com/ is resolved
> 
> Nope bug is on http://tinybuild.com/ This is mp4 (video?) file, not audio
> file.

It's the different problem, this issue would be solved in bug1235612.
Flags: needinfo?(amarchesini)
I suggest to make a meta bug to track all Flash-related sound indicator issues, because lately all such bugs occur on their side. This bug could be used for this. I'll write the rest info anyway.

Flash 21_0_0_182, Win7_64:
Sometimes when I click progressbar in Flash player on Twitch TV, sound indicator disappears. Pressing Ctrl+M in this case still _shows_ muted icon, but it doesn't really mute the sound.
Workaround: to pause the video and click "play" again.
I'm closing a lot of bugs which are filed as Adobe Flash bugs which are either irrelevant, not actionable, or not serious enough to track in the Mozilla bug tracker. For the most part, Flash bugs should be filed in Adobe bugbase, and we'll only track a few highly-critical issues in the Mozilla tracker.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INCOMPLETE
Just a quick heads-up: mute button still (again?) does not work on (Ubuntu) Linux 16.04 with Flash 24,0,0,194 (the latest according to http://www.adobe.com/software/flash/about/) and Firefox 50.1.0. The speaker correctly shows on the tab, clicking it toggles the icon ("sound" to "no sound" and vice-versa), but the sound is not actually muted.

Example site: http://armorgames.com/play/15760/gemcraft-chasing-shadows
Balazs, what you mention is tracked in bug 1325592.
You need to log in before you can comment on or make changes to this bug.