Closed Bug 1240528 Opened 9 years ago Closed 9 years ago

Unable to read text on Linux notifications - blank, white bar displayed

Categories

(Firefox :: Theme, defect)

44 Branch
defect
Not set
major

Tracking

()

VERIFIED FIXED
Tracking Status
firefox43 --- unaffected
firefox44 + verified
firefox45 --- unaffected
firefox46 --- unaffected

People

(Reporter: standard8, Assigned: Gijs)

References

Details

Attachments

(2 files)

STR

1) Go to a page which produces a warning in a notification bar. For example http://www.popuptest.com/popuptest3.html or start a Hello conversation and enable tab sharing.
2) Wait for the notification bar to come up.
3) Try and read it

Actual Results

The bar is white on white.

Expected Results

Readable text on the bar.

I'm using Ubuntu with the default settings. On 43 the bar has a black background and white text.

[Tracking Requested - why for this release]: Users can't read the notifications to understand why the page has generated a warning, or what the page is telling them.

In the case of Hello, this would be the warning that Firefox is sharing their tabs.
FF 44 seems the only one affected. 45 & 46 have a yellow background with grey text.
Severity: normal → major
Oh ffs.

If only gtk2 and gtk3 weren't so different, and we had more than "nobody" using beta on Linux.


It might be too late to fix this even when we figure out what's going wrong here. :-\
I can't reproduce - I get black text on an off-white background.

Does setting the element's style's "color" property to -moz-gtk-info-bar-text help?
Flags: needinfo?(standard8)
Florin can your team test these STR on linux/ubuntu and tell me how often this happens?
Flags: needinfo?(florin.mezei)
Assigning to Andrei so he can get someone to investigate this.
Flags: needinfo?(florin.mezei) → needinfo?(andrei.vaida)
Attached image issue.png
I've reproduced the issue on Ubuntu 13.10 x86 and Ubuntu 14.04 x86/x64 using Firefox 44 RC (buildID: 20160118143821). 

The issue is reproducible on http://www.popuptest.com/popuptest3.html page and also when enabling the tab sharing on a Hello Conversation . I can't read the text on notifications because the Notification Bar is displayed with the white color on a white background. Please see attachment "issue.png".
Flags: needinfo?(andrei.vaida)
After digging with Mark earlier, it seems I broke this in bug 1162635 when removing the InfoBackground background color.
Blocks: 1162635
I'm on Ubuntu 15.04 if that helps. Using all the default settings.

I believe this affects gtk2 only (which I believe is the default). The approximate list of notifications that I think this affects is:

- Hello tab sharing
- Popup blocker
- Plugin crashes (for where we show the notification bar)
- Some EME/DRM notifications
- Add-on installation/restarts
- Tab group removal
- Slow add-on
- Sync notifications
Flags: needinfo?(standard8)
I believe this should work, but rc has already been built. Apparently we might do an rc2, though, so here goes nothing. Will test on my VM as soon as it's done enlarging its disk and I can finish building, but testing with the devtools by Mark suggests this should work.
Attachment #8709388 - Flags: review?(dao)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 8709388 [details] [diff] [review]
Patch for release

Approval Request Comment
[Feature/regressing bug #]: bug 1162635 and bug 1227024
[User impact if declined]: unreadable notification bars, see comment 9
[Describe test coverage new/current, TreeHerder]: no, appearance only
[Risks and why]: low risk, specifically puts back an earlier background-color rule to make sure the notification bars are readable again
[String/UUID change made/needed]: no
Attachment #8709388 - Flags: approval-mozilla-beta?
(In reply to :Gijs Kruitbosch from comment #10)
> Comment on attachment 8709388 [details] [diff] [review]
> Patch for beta
> 
> Approval Request Comment
> [Feature/regressing bug #]: bug 1162635 and bug 1227024
> [User impact if declined]: unreadable notification bars, see comment 9

Egh, meant comment #8.
(In reply to :Gijs Kruitbosch from comment #9)
> Created attachment 8709388 [details] [diff] [review]
> Patch for beta
> 
> I believe this should work, but rc has already been built. Apparently we
> might do an rc2, though, so here goes nothing. Will test on my VM as soon as
> it's done enlarging its disk and I can finish building, but testing with the
> devtools by Mark suggests this should work.

Just to clarify, I made the extra rule conditional on gtk2 because I intend to patch aurora and central in similar fashion to avoid this regressing, and because it seems plausible that distros may or may not decide to also stick with gtk2 and/or use gtk3. -moz-gtk-info-bar-text really means InfoText on gtk2 (but not on gtk3). AFAICT -moz-appearance: -moz-gtk-info-bar is a no-op on gtk2. I don't know exactly when that happened, some of the notification bar patches for gtk3 initially patched a single gtkdrawing.c file, but we now seem to have separate files for gtk2 and gtk3, and only the latter has code for -moz-gtk-info-bar.
Attachment #8709388 - Flags: review?(dao) → review+
Comment on attachment 8709388 [details] [diff] [review]
Patch for release

I'm being told that we've already merged beta to release, so updating things for that. Pinging ritu for the approval.

Approval Request in Comment 10

(In reply to :Gijs Kruitbosch from comment #9)
> Created attachment 8709388 [details] [diff] [review]
> Patch for beta
> 
> I believe this should work, but rc has already been built. Apparently we
> might do an rc2, though, so here goes nothing. Will test on my VM as soon as
> it's done enlarging its disk and I can finish building, but testing with the
> devtools by Mark suggests this should work.

I've verified with a local build that this fixes the issue.
Attachment #8709388 - Attachment description: Patch for beta → Patch for release
Flags: needinfo?(rkothari)
Attachment #8709388 - Flags: approval-mozilla-beta? → approval-mozilla-release?
Comment on attachment 8709388 [details] [diff] [review]
Patch for release

This is a pretty core scenario which primarily affects linux users. Given that this was locally tested by Gijs to make sure it fixes the problem, let's uplift to moz-release so this can be included in RC2.
Flags: needinfo?(rkothari)
Attachment #8709388 - Flags: approval-mozilla-release? → approval-mozilla-release+
Flags: qe-verify+
I verified using Firefox 44.0RC build 2 on Ubuntu 14.04 32-bit and 64-bit, with various infobars (hello sharing, install addons, pop-ups, plugin crash).
Status: RESOLVED → VERIFIED
Blocks: 1241621
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: