Closed Bug 1241106 Opened 4 years ago Closed 4 years ago

[e10s] On shutdown content crashes can occur without submission means

Categories

(Firefox :: General, defect, P1)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1269998
Tracking Status
e10s + ---

People

(Reporter: jonathan, Unassigned)

References

Details

Content crashes only get submitted through the tab UI but this can already be removed by the time such crashes occur.

My speculation is that these may be accounting for ~40% of crashes showing up in telemetry. Bug 1222890

Also my speculation is most are killhards after hitting dom.ipc.tabs.shutdownTimeoutSecs.
Blocks: 1234647
tracking-e10s: --- → ?
What we need here is some sort of UX that opens in a tab on startup that gives the user the chance to approve the submit.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(dolske)
Priority: -- → P1
Flags: needinfo?(dolske) → needinfo?(philipp)
Redirecting this to Bram while I'm out so that it's not blocked on me...
Could we just open the crash reporter in a background tab on startup?
Flags: needinfo?(philipp) → needinfo?(bram)
Is it reasonable to move this “Report errors like this to Mozilla” interface to about:sessionrestore?

It should be a checkbox like that which is present on this page: https://expired.badssl.com/

When you check it, we automatically send a report. When you uncheck it, we stop sending (of course, we still send the error you just reported, but we won’t send the next one).

The benefit: for users, there’s no need to click “Submit” every single time. For us, we’ll get more crash data.

If not, let’s go with Philipp’s idea on comment 2: open the crash reporter UI on startup. As long as it’s not annoying or blocking user from continuing his task, it’s all good.
Flags: needinfo?(bram)
Would need to take account of browser.sessionstore.max_resumed_crashes if using session restore.
Possibility of there being more than one crash report.
If there are more than one crash report, how shall we handle it? I think we can still use the same interface, but there are a few things to consider:

* Is it more helpful to us to get more data from both reports, instead of just one?
* Or is it more confusing for the user if we say “Click to submit reports from all recent crashes”?
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1269998
You need to log in before you can comment on or make changes to this bug.