When using redbox.com no film reviews are visible unless I clear cookies and cache every day. redbox says it's you guys I don't know. This never was a problem before.

RESOLVED WORKSFORME

Status

Tech Evangelism
Desktop
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: moshmeister7, Unassigned)

Tracking

Firefox 43
x86_64
Windows 10

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

Steps to reproduce:

visit redbox.com pull up a movie scroll down to reviews at the bottom.


Actual results:

No reviews visible 


Expected results:

reviews visible for all movioes

Comment 1

2 years ago
Access Denied
You don't have permission to access "http://www.redbox.com/" on this server.
Unfortunately I don't have permission access to redbox.com site, tried on Windows 10 on
 - Nightly 46.0a1, Build ID 20160124030209, User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
 - Releases 43.0.4, Build Id 20160105164030, User Agent Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0

Reporter, can you please verify if this issue still occurs using Firefox in safe mode or with a new profile?
http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles


Also, can you please try to see if this is reproducible on Chrome. I tried to open the redbox.com page using Chrome, but still don't have access.
Flags: needinfo?(moshmeister7)
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Comment 3

2 years ago
Similar issue (same error message about denies access) with another website, see bug 1242306.
See Also: → bug 1242306

Comment 4

2 years ago
Both have the same traceroute and end to akamaiedge.net:
1) Redbox: http://network-tools.com/default.asp?prog=trace&host=www.redbox.com%2F
(a172-226-61-244.deploy.static.akamaitechnologies.com)
2) Macys: http://network-tools.com/default.asp?prog=trace&host=http%3A%2F%2Fwww.macys.com%2Faccount%2Fsignin
(a172-233-68-125.deploy.static.akamaitechnologies.com)

Updated

2 years ago
Component: Untriaged → Desktop
Product: Firefox → Tech Evangelism
Version: 43 Branch → Firefox 43

Updated

2 years ago

Comment 5

2 years ago
First, redbox.com doesn't exist.

→ ping redbox.com
PING redbox.com (206.18.125.29): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
Request timeout for icmp_seq 4
Request timeout for icmp_seq 5
Request timeout for icmp_seq 6
Request timeout for icmp_seq 7
Request timeout for icmp_seq 8
Request timeout for icmp_seq 9
Request timeout for icmp_seq 10
^C
--- redbox.com ping statistics ---
12 packets transmitted, 0 packets received, 100.0% packet loss

but www.redbox.com does.
→ ping www.redbox.com
PING e8932.b.akamaiedge.net (104.70.139.7): 56 data bytes
64 bytes from 104.70.139.7: icmp_seq=0 ttl=56 time=18.989 ms
64 bytes from 104.70.139.7: icmp_seq=1 ttl=56 time=18.387 ms
64 bytes from 104.70.139.7: icmp_seq=2 ttl=56 time=20.068 ms
64 bytes from 104.70.139.7: icmp_seq=3 ttl=56 time=16.164 ms
^C
--- e8932.b.akamaiedge.net ping statistics ---
4 packets transmitted, 4 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 16.164/18.402/20.068/1.426 ms


And it's indeed akamaiedge server. And indeed we get a 403

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate
Connection: keep-alive
Host: www.redbox.com
User-Agent: HTTPie/0.9.2

HTTP/1.1 403 Forbidden
Connection: close
Content-Length: 264
Content-Type: text/html
Date: Tue, 26 Jan 2016 00:36:24 GMT
Expires: Tue, 26 Jan 2016 00:36:24 GMT
Mime-Version: 1.0
Server: AkamaiGHost
access-control-allow-credentials: true
access-control-allow-headers: Content-Type, Accept, Pragma
access-control-allow-methods: GET
access-control-allow-origin: *
access-control-max-age: 3600

with any browsers and both on http and https.


In https://en.wikipedia.org/wiki/Redbox I see
Area served: North America

I wonder if Mike receives something that I don't in Japan.
Flags: needinfo?(miket)

Comment 6

2 years ago
"Rent movies online at Redbox.com, where you can reserve and preview new DVDs, Blu-Rays and games."

Maybe they apply some nasty georestriction to visitors.

Comment 7

2 years ago
possible. btw, I tried also with 
   network.http.spdy.enabled; false
and it didn't solve the issue. Because of the comment in Bug 1242306
Created attachment 8712370 [details]
redbox.gif

I'm not able to reproduce in 43 in a relatively clean profile (no add-ons installed, no customizations). See attached gif.
Flags: needinfo?(miket)
I get "Access denied" too. Only N-America I guess.
@Reporter: I see the reviews: is this still an issue?
Name 	Firefox
Version 	43.0.4
Build ID 	20160105164030
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0
I can also see them in Nightly.
Name 	Firefox
Version 	47.0a1
Build ID 	20160127030236
Based on the last comments #8 and #10, this bug can be marked Resolved - WORKSFORME.
Reporter if you still can reproduce the bug, please reopen and provide additional information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(moshmeister7)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.