[Win32] Mozilla doesn't expose keyboard focus (eg to screen magnifier)

RESOLVED FIXED in mozilla1.0.1

Status

()

Core
Event Handling
P1
enhancement
RESOLVED FIXED
19 years ago
16 years ago

People

(Reporter: cpratt, Assigned: John Gaunt (redfive))

Tracking

(Blocks: 1 bug, {access, helpwanted, pp})

Trunk
mozilla1.0.1
x86
Windows 98
access, helpwanted, pp
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: accessibility)

(Reporter)

Description

19 years ago
Build ID: 1999082008 (M10 build)
Platform: Windows 98 (this bug has to do with Windows-specific features)

To reproduce:
- If you don't have the Windows 98 Accessibility tools installed, install them
using the Add/Remove Programs control panel. (Hint: If you don't have the CD
available, and are a Netscape employee, our licensed copy is at
\\surge\dist\os\win98 .)
- In the Start menu, select Programs | Accessories | Accessibility | Magnifier
to open the Magnifier Settings. The default settings are acceptable.
- Launch apprunner.
- Watch as the DOS window correctly shows in the Magnifier part of your screen;
note that as it exposes keyboard focus to Windows 98, the currently 'active'
line is in the center of the Magnifier window. This is a decent example of what
Magnifier should do.
- Wait for the main browser window to finish loading. Make sure that it is the
frontmost (active) window.
- Move the cursor somewhere away from apprunner.
- Press Alt-F to drop down the file menu.

Result: In the Magnifier window, focus is not switched to where you are
currently navigating using the keyboard, allowing you to see what you're doing.

Expected result: Apprunner should expose keyboard focus, allowing accessibility
tools for the disabled to work with Apprunner.

Updated

19 years ago
Blocks: 15693

Comment 1

19 years ago
what's the status of this bug? which milestone is this slotted for?

Updated

19 years ago
Target Milestone: M15

Updated

19 years ago
Keywords: pp

Updated

19 years ago
Summary: [PP] Win32 - Apprunner doesn't expose keyboard focus → Win32 - Apprunner doesn't expose keyboard focus

Comment 2

18 years ago
Saari, hate to dump a bug on you but you seem better able to fix this one than I 
currently, given your recent focus and menu work.
Assignee: joki → saari

Comment 3

18 years ago
Wow. Um, okay... So how does one "expose" focus on Windows? Do I need to be 
generating events and giving them to the default proc? This is going to be tricky 
at best since the keyboard menu navigation is done via a capturing listener, and 
focus isn't really there in any way shape or form. We may have to add keyboard 
focus memory.
Status: NEW → ASSIGNED

Comment 4

18 years ago
I'm moving this to M17 if only because I don't have the first clue of how to 
proceed with it. Someone will probably push back.
Target Milestone: M15 → M17

Comment 5

18 years ago
Mass moving M17 bugs to M18
Target Milestone: M17 → M18

Comment 6

18 years ago
I think what he means by "exposing keyboard focus" is that when as in his 
example you hit Alt + F, the magnifier window should show you what is now active 
which is the top item on the file menu.  Currently what it shows you is some 
"random" place on the screen; often but not always wherever the mouse it.

I believe the bug here is that the magnifier doesn't follow the active areas of 
the screen when you use the keyboard.  Note in the above example that if you 
arrow down through the menu, the magnifier doesn't follow you as it should.

Comment 7

18 years ago
mass-moving all bugs to m21 that are not dofood+, or nsbeta2+
Target Milestone: M18 → M21

Updated

18 years ago
Target Milestone: M21 → Future

Comment 8

18 years ago
Mass update:  changing qacontact to ckritzer@netscape.com
QA Contact: janc → ckritzer

Updated

18 years ago
Blocks: 12952, 24413
Keywords: access
Summary: Win32 - Apprunner doesn't expose keyboard focus → [Win32] Mozilla doesn't expose keyboard focus

Comment 9

18 years ago
Updating QA Contact.
QA Contact: ckritzer → lorca

Comment 10

18 years ago
I suppose that means I should hunt through msdn or borland's help for the
function to hint to the os what we're doing.
Keywords: helpwanted
Whiteboard: [need info]
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok

Comment 12

18 years ago
Sounds like part of the accessiblity work that should be solved by implementing
the MSAA server. ->evaughan, p1 enhancement for moz0.9, cc aaron, hyatt, saari,
self
Assignee: saari → evaughan
Severity: major → enhancement
Status: ASSIGNED → NEW
Priority: P3 → P1
Target Milestone: Future → mozilla0.9

Comment 13

17 years ago
->moz0.9.1
Target Milestone: mozilla0.9 → mozilla0.9.1

Comment 14

17 years ago
This is being implemented as a part of accessibility feature
Status: NEW → ASSIGNED
Whiteboard: [need info] → accessibility

Updated

17 years ago
Blocks: 65632

Comment 15

17 years ago
John's bug now.
Assignee: evaughan → jgaunt
Status: ASSIGNED → NEW
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9.2
(Assignee)

Comment 16

17 years ago
fixed for embedding need to complete for xul
Target Milestone: mozilla0.9.2 → mozilla1.0

Comment 17

17 years ago
Does Mozilla have a way to find out where on the screen the focused element is?
See also bug 81723, keyboard context menu should open near focused item.

Comment 18

17 years ago
You can ask the focus controller what the currently focused element is, and then
find its primary frame and work back up the frame and view trees to determine
wherer you are. Gross eh?

Comment 19

17 years ago
QA contact updated
QA Contact: gerardok → madhur

Updated

17 years ago
Summary: [Win32] Mozilla doesn't expose keyboard focus → [Win32] Mozilla doesn't expose keyboard focus (eg to screen magnifier)

Comment 20

17 years ago
Once XUL accessibility bug 82207 is fixed, this is fixed.
Depends on: 82207

Comment 21

17 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 22

17 years ago
Any remaining focus issues are part of our active accessibility meta bug 82207
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Updated

16 years ago
QA Contact: madhur → rakeshmishra

Updated

16 years ago
QA Contact: rakeshmishra → trix
You need to log in before you can comment on or make changes to this bug.