Closed Bug 1242463 Opened 4 years ago Closed 3 years ago

Create some basic printing tests.

Categories

(Core :: Printing: Output, defect)

All
Windows
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1299848

People

(Reporter: bobowen, Unassigned)

References

(Blocks 2 open bugs)

Details

On Windows (and possibly any platform), the only test that I believe exercises any of the print rendering code is:
toolkit/components/jsdownloads/test/browser/browser_DownloadPDFSaver.js 

(It's arguable that this shouldn't be even running on Windows, because I don't believe we offer the functionality and I think it was originally developed for Android.)

Once we have bug 1156742 fixed, we should be able to at least record prints in the child and play them back with a dummy translator in the parent.

This dummy translator could be back by an off screen DrawTarget or possibly on Windows an EMF file.
It might be possible to do comparisons of printed images.
Duplicate of this bug: 1314780
Blocks: 1302489
Finally got some time to start looking at the plan for this that I discussed with people at the last all hands.
Assignee: nobody → bobowencode
Status: NEW → ASSIGNED
Bob, are you currently working on this?
Flags: needinfo?(bobowencode)
No, because tobytailor seemed to be much further down the line to creating some in bug 1299848, so I stopped looking into it.
Nothing has landed from bug 1299848 as yet though.
Assignee: bobowencode → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(bobowencode)
Let's dupe this bug with bug 1299848 as it's mostly sharing same purpose.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1299848
You need to log in before you can comment on or make changes to this bug.