Firefox 44 takes much longer to load up with add-on "Custom Buttons"

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: John Allen, Unassigned)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160123151951

Steps to reproduce:

Double click Firefox icon.
Waited for Firefox to load.


Actual results:

Any time I start Firefox, after the v44.0 upgrade, it took 15-45 seconds for Firefox to start.


Expected results:

The previous version of Firefox, before the upgrade, took anywhere from 3 - 7 seconds to load.

Comment 1

2 years ago
Could you test:
1) in safe mode:
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

2) with a fresh profile:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

same issue when starting FF44?
Flags: needinfo?(lotusteadragon)
(Reporter)

Comment 2

2 years ago
(In reply to Loic from comment #1)
> Could you test:
> 1) in safe mode:
> https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-
> mode
> 
> 2) with a fresh profile:
> https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-
> firefox-profiles
> 
> same issue when starting FF44?

Disabling all of the add-ons (I only have 5, but still) pointed out the problem. Singling them out, and starting up with each, I found that I have an add-on called "Custom Buttons 0.0.5.8.1" that seems to be reacting poorly to the latest version of FF.
Flags: needinfo?(lotusteadragon)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Comment 3

2 years ago
If it's back, use the reset feature to keep only your private data:
https://support.mozilla.org/en-US/kb/reset-firefox-to-fix-most-problems

Updated

2 years ago
Duplicate of this bug: 1243552

Updated

2 years ago
Summary: Firefox 44 takes much longer to load up in Windows 10. → Firefox 44 takes much longer to load up with add-on "Custom Buttons"

Comment 5

2 years ago
Jorge, is it possible to contact the add-on author or flag the add-on incompatible with FF44?
Component: Untriaged → Extension Compatibility
Flags: needinfo?(jorge)
Can the problem be reproduced? I gave it a try and couldn't, so it's likely that there's a set of custom buttons you need to have in Firefox in order to trigger this bug.
Flags: needinfo?(jorge)
You need to log in before you can comment on or make changes to this bug.