"Save Image As..." Not working

VERIFIED FIXED in Firefox 47

Status

()

Firefox
File Handling
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: Sahil Zubair, Assigned: mconley)

Tracking

({regression, reproducible})

47 Branch
Firefox 47
x86_64
Windows 7
regression, reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10sm8+, firefox46 unaffected, firefox47 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160127030236

Steps to reproduce:

Updated to 47.0a1 (2016-01-27)
Right click on image file
Select "Save Image As..." in context menu
Choose save directory and click save



Actual results:

Save dialog closes but file is not downloaded and no indication that download was started

No issues with "Save Page As..." or "Save Video As..." or "Save Snapshot As..."

I tried again with a new profile and the issue was not resolved. The issue does not occur in 44.0.


Expected results:

Indication that download has started
(Reporter)

Updated

2 years ago
Component: Untriaged → File Handling
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64

Comment 1

2 years ago
[Tracking Requested - why for this release]:

Pushlog:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=59c5826c1280c0568705b04842e34815da52d6d2&tochange=9bf3cfaeeedc5896c590575eeb8aa57ed530a7fe

Regressed by: Bug 1233497


Error on Brouser Console:

unsafe CPOW usage forbidden contentAreaUtils.js:404:0
Blocks: 1233497
Status: UNCONFIRMED → NEW
status-firefox47: --- → affected
tracking-e10s: --- → ?
Ever confirmed: true
Flags: needinfo?(mconley)
Keywords: regression, reproducible
Assignee: nobody → mconley
Flags: needinfo?(mconley)
Thanks for filing, Sahil, and thanks for connecting me, Alice0775.
tracking-e10s: ? → m8+
Created attachment 8713346 [details] [diff] [review]
Deprecate unsafe CPOW usage in contentAreaUtils' saveImage
Created attachment 8713349 [details] [diff] [review]
Don't pass unsafe CPOWs to saveImageURL when offering to save media to disk
https://treeherder.mozilla.org/#/jobs?repo=try&revision=1cc1c8cc6ad2

Updated

2 years ago
Duplicate of this bug: 1244084
Comment on attachment 8713349 [details] [diff] [review]
Don't pass unsafe CPOWs to saveImageURL when offering to save media to disk

Is this sort of stuff still swapped into your brain, jld? Or should I redirect?
Attachment #8713349 - Flags: review?(jld)
Attachment #8713346 - Flags: review?(jld)
Comment on attachment 8713346 [details] [diff] [review]
Deprecate unsafe CPOW usage in contentAreaUtils' saveImage

Review of attachment 8713346 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, and thanks for adding that function comment.
Attachment #8713346 - Flags: review?(jld) → review+
Attachment #8713349 - Flags: review?(jld) → review+
Aside: if there's a meta-bug for improving our test frameworks to make it easier to write automated regression tests for things like this, it'd be worth cross-referencing this bug.
It gets tricky, since our mochitests inherit the add-on shims. I will file a bug about seeing if we can start turning that off test by test. Thanks for the idea.
Actually, come to think of it, a test that exercises the image saving case should have caught this, since the unsafe CPOW access occurred asynchronously inside internalSave.

I've filed bug 1244260 to get a test for this written.
See Also: → bug 1244260
https://hg.mozilla.org/integration/fx-team/rev/eb1acf2e2d72f120874f8d624d54e34d8a7ddeec
Bug 1243643 - Deprecate unsafe CPOW usage in contentAreaUtils' saveImage. r=jld

https://hg.mozilla.org/integration/fx-team/rev/7ae2adc4bb4400d9f6bf52eee2b046c3644c8776
Bug 1243643 - Don't pass unsafe CPOWs to saveImageURL when offering to save media to disk. r=jld

Comment 13

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/eb1acf2e2d72
https://hg.mozilla.org/mozilla-central/rev/7ae2adc4bb44
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox47: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
Duplicate of this bug: 1244005
I have reproduced this bug on Nightly 47.0a1 (2016-01-27) on ubuntu 14.04 LTS, 32 bit!

The bug's fix is now verified on Latest Nightly 47.0a1!

Build ID: 20160203030249
User Agent: Mozilla/5.0 (X11; Linux i686; rv:47.0) Gecko/20100101 Firefox/47.0
QA Whiteboard: [bugday-20160203]
Duplicate of this bug: 1245592
Depends on: 1246244
Is this still an m8 blocker?  Should this uplift to 46? Thanks.
status-firefox46: --- → affected
Flags: needinfo?(mconley)
I think we're still okay here - what broke this was CPOW outlawing, which landed in bug 1233497 in 47. 46 shouldn't be affected.
Flags: needinfo?(mconley)
OK, great.
status-firefox46: affected → unaffected

Comment 20

2 years ago
I managed to reproduce this bug on an affected build, i.e. 47.a1 (2016-01-27) using Windows 10 x64.
This bug is confirmed fixed on 47.0b.3.
[testday-20160506]
Updating this bug's status based on Comment 20.
Status: RESOLVED → VERIFIED
status-firefox47: fixed → verified
You need to log in before you can comment on or make changes to this bug.