If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[TV] [FTE] Send to TV new String - AndroidTM

VERIFIED FIXED

Status

Firefox OS
Gaia::TV
P2
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: twen, Assigned: Fischer)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.5+)

Details

(Whiteboard: [ft:conndevices])

Attachments

(1 attachment)

55 bytes, text/x-github-pull-request
rexboy
: review+
Details | Review | Splinter Review
(Reporter)

Description

2 years ago
Based on the new strings change, https://docs.google.com/spreadsheets/d/1Xb_R00AoFXR9UY3CGln9yygm0GyFqy0zaHEWbjSfKpw/edit#gid=1902430450 trademark should be added next to Android strings. 

This bug is to address string change in the following areas for Send to TV app:

1. Download Firefox for [AndroidTM] to interact with your Firefox OS TV.
2. Make sure your [AndroidTM] device is using the same Wi-Fi network as the TV.
3. While playing a video in Firefox on your [AndroidTM] device, tap on the Send to icon {{icon}} that appears either on the address bar or on the video player to send the video to your TV.
4. Learn how to send tab from [AndroidTM] device
5. Download and install add-on to Firefox on your [AndroidTM] device.
(Reporter)

Updated

2 years ago
Blocks: 1239346
blocking-b2g: --- → 2.5?

Updated

2 years ago
Whiteboard: [ft:conndevices]

Comment 1

2 years ago
Hi Fischer,
Please also keep this in your bucket.
Flags: needinfo?(fliu)
Priority: -- → P2
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1243283

Comment 3

2 years ago
According to partner:

We use the same English word for all different languages with respect to
the term "Android TM". This would be explained to the translation
company when we order the translation item.

@Fischer, Please help to make the change. Thanks.

Updated

2 years ago
Assignee: nobody → fliu
blocking-b2g: 2.5? → 2.5+
(Assignee)

Comment 4

2 years ago
There should be 6 sentences requiring changed:

1. Download Firefox for [AndroidTM] to interact with your Firefox OS TV.
2. Make sure your [AndroidTM] device is using the same Wi-Fi network as the TV.
3. While playing a video in Firefox on your [AndroidTM] device, tap on the Send to icon {{icon}} that appears either on the address bar or on the video player to send the video to your TV.
4. Learn how to send tab from [AndroidTM] device
5. Download and install add-on to Firefox on your [AndroidTM] device.
6. While using Firefox on your [AndroidTM] device, tap on the Send to icon {{icon}} that appears on the address bar to send tabs to your TV.
Flags: needinfo?(fliu)
(Assignee)

Comment 5

2 years ago
Created attachment 8725576 [details] [review]
PR #12

@Rex,

This patch
- Update strings
- Modify styles for new string updates based on checking with designer Peko.
Thanks
Attachment #8725576 - Flags: review?(rexboy)
Attachment #8725576 - Flags: review?(rexboy) → review+
(Assignee)

Comment 6

2 years ago
Land to master: https://github.com/mozilla-b2g/casting-tutorial/commit/b91d77ce2b835e46ac5a5694d3826cecb4959a56
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Comment 7

2 years ago
Verify this issue on both v2.5 and v2.6 latest build and the result is PASS.
The 6 sentences are changed correctly.
1. Download Firefox for [AndroidTM] to interact with your Firefox OS TV.
2. Make sure your [AndroidTM] device is using the same Wi-Fi network as the TV.
3. While playing a video in Firefox on your [AndroidTM] device, tap on the Send to icon {{icon}} that appears either on the address bar or on the video player to send the video to your TV.
4. Learn how to send tab from [AndroidTM] device
5. Download and install add-on to Firefox on your [AndroidTM] device.
6. While using Firefox on your [AndroidTM] device, tap on the Send to icon {{icon}} that appears on the address bar to send tabs to your TV.


[Build Info]
2.6 TV Simulator
gaia:
https://github.com/mozilla-b2g/gaia/commit/f41e046a5c6032d9ce281fdb96256be7fc9b0c0f
gecko:
https://hg.mozilla.org/mozilla-central/rev/2b5237c178ea02133a777396c24dd2b713f2b8ee

2.5 TV Simulator
gaia:
https://github.com/mozilla-b2g/gaia/commit/71952d4b5417796380ddab274c5566a8eced2f8b
gecko:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/0b279b0579ae5656e3df34d522af06800e0a03bf
mulet:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/9d519d3bedacb7f5ce467f4c6bef7ff55ff3b0f3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.