If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

pressing back button without effect

RESOLVED DUPLICATE of bug 88684

Status

()

Core
Document Navigation
RESOLVED DUPLICATE of bug 88684
16 years ago
9 years ago

People

(Reporter: Christian Schweer, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Pressing the back button has no effect at some sites using frames.

Example:
1. Goto http://informer2.comdirect.de/ (sorry, I don't have an english example)
2. click on any link (e.g. a chart) in the inner frame
3. press the back button
Result: back button without effect

Alternative:
2. click on the link "News-Informer" in the navigation-frame
3. click on any link in the inner frame
4. press the back button
Result: back button without effect

Side-effects:
- Pressing the reload-button after the back-button loads the "missing" page
- if you click on a link in the inner frame instead of pressing the back-button,
 the first back-action will act normally, but the second back-action will hang
again (reloading works, too)
session history
Assignee: jkeiser → radha
Component: HTMLFrames → History: Session
QA Contact: amar → claudius
(Reporter)

Comment 2

16 years ago
correction: pressing the reload button reloads the whole frameset (as it should
do IMHO).

in the given examples this reloads the missing page, because it is loaded by the
frameset initially.

using "right-click -> reload frame" still reloads the wrong page
(Reporter)

Comment 3

16 years ago
just downloaded the latest nightly 20020212.
problem still exists.
88684 already lists the problem with this site and I'm working on it. 

*** This bug has been marked as a duplicate of 88684 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.