Closed Bug 1243799 Opened 6 years ago Closed 5 years ago

tracking protection: Spotify doesn't display the pop-up to log with Facebook

Categories

(Firefox :: Protections UI, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1226498

People

(Reporter: marioyanesp, Unassigned)

References

(Blocks 1 open bug, )

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160123151951

Steps to reproduce:

1- Enter play.spotify.com
2- Log in with Facebook


Actual results:

The window to log with Facebook doesn't appear. In others browsers, it appears.


Expected results:

The window should appear.
Are you doing this in private browsing and/or did you enable tracking protection outside of private browsing ? Can you reproduce with a new profile? ( https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles )

I tested this and I do get a Facebook login window popping up.
Flags: needinfo?(marioyanesp)
Yes, it's an issue with tracking protection (no need to be in PB mode).
With TP enabled, the login page loads during 1 min (from amazonaws.com cloud) and Firefox fails to display the Facebook pop-up after clicking on the link.
Blocks: tp-breakage
Component: Untriaged → DOM: Security
Flags: needinfo?(marioyanesp)
Product: Firefox → Core
Summary: Spotify doesn't appear window → tracking protection: Spotify doesn't display the pop-up to log with Facebook
Are you sure this is a result of tracking protection? I ran into a very similar-sounding bug, which I bisected to something totally different. See bug 1252974.

myanesp, what version of Firefox did you see this issue on?
Flags: needinfo?(marioyanesp)
Flags: needinfo?(epinal99-bugzilla2)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #3)
> Are you sure this is a result of tracking protection? I ran into a very
> similar-sounding bug, which I bisected to something totally different. See
> bug 1252974.
> 
> myanesp, what version of Firefox did you see this issue on?

This bug is about FF44, your regression range in bug 1252974 is for FF47. Just open FF44, enable TP and you'll see it's reproducible.
Flags: needinfo?(epinal99-bugzilla2)
Component: DOM: Security → Safe Browsing
Product: Core → Toolkit
Flags: needinfo?(marioyanesp)
Component: Safe Browsing → Tracking Protection
Product: Toolkit → Firefox
Version: 44 Branch → unspecified
Whiteboard: [platform-rel-Facebook]
platform-rel: --- → ?
platform-rel: ? → ---
Whiteboard: [platform-rel-Facebook]
Duplicate of this bug: 1210651
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1226498
Blocks: tplogin
No longer blocks: tp-breakage
You need to log in before you can comment on or make changes to this bug.