Breaks MAPI32.dll for GroupWise

VERIFIED DUPLICATE of bug 109362

Status

MailNews Core
Simple MAPI
VERIFIED DUPLICATE of bug 109362
16 years ago
10 years ago

People

(Reporter: Sean Crandall, Assigned: Rajiv Dayal)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla appears to replace MAPI32.dll in the system root directory.  After I
install Mozilla 0.9.8, the next time I boot Windows, the GroupWise notifier is
unable to load.  When I manually start GroupWise, I get the error message
"Ordinal Not Found," with the text "The ordinal 19 could not be located in the
dynamic link library MAPI32.dll."  Comparison with the current MAPI32.dll
reveals that it is the same MAPI32.dll that ships with Mozilla.  Re-installing
MAPI32.dll from the GroupWise Windows Messaging pakage fixes the problem, but at
one point, Mozilla apparently autonomously replaced it again.
yay dll hell.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

16 years ago
The reason the dll is replaced again is because currently Mozilla makes itself
the default mail application by default, see bug # 120134 and the fix for bug #
123596 should fix this problem about Mozilla replacing Mapi32.dll autonomously
too. No patch there yet but coming up in next 2-3 days.

For the "ordinal not found error" there is another bug for the groupwise
problem, see bug # 109362.
(Assignee)

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 109362 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
verified dupe
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.