[TV][2.5] The strings in error page is wrong when browsing a page without network connection.

RESOLVED DUPLICATE of bug 1253488

Status

Firefox OS
Gaia::TV::Browser
--
minor
RESOLVED DUPLICATE of bug 1253488
3 years ago
2 years ago

People

(Reporter: cindylee, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ft:conndevices], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
[Description]
[TV][2.5] The strings in error page is wrong when browsing a page without network connection.

[Test Steps]
1. Launch Browser.
2. Disconnect the network.
3. Browse a website.
4. Pop up "The page cannot be displayed" dialog with "OK" button.
5. Press "OK" button.
6. Shows first string - "Server not found"
   second string - "Can’t find the server at {{website title}}"

[Expected Result]
6. Shows first string - "Need an Internet Connection"
   second string - "{{website title}} requires an Internet connection."

[Actual Result]
6. Shows first string - "Server not found"
   second string - "Can’t find the server at {{website title}}"

[Frequency]
5/5

[Build Info]
Environment: 2.5 Simulator
gaia:https://github.com/mozilla-b2g/gaia/commit/8a0d9deb2cd47df25750ed2c6820909e4feac3bb
gecko:https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/2b6f8826861a846c3d1d98ef595c8dfbf8b59328
mulet:https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/2b6f8826861a846c3d1d98ef595c8dfbf8b59328 

[TCID]
17988

Comment 1

3 years ago
bug1236852 still not landed, this case should be verified again once the network error UI polish finished
Depends on: 1236852
Blocks: 1239346
QA Whiteboard: [COM=TV Browser]

Comment 2

3 years ago
Hi Cindy, please help to verify this issue again since the polish bug1236852 already landed on master.
Flags: needinfo?(cindylee)
(Reporter)

Comment 3

3 years ago
(In reply to Mike Lien[:mlien] from comment #2)
> Hi Cindy, please help to verify this issue again since the polish bug1236852
> already landed on master.

Hi Mike, I check the UI SPEC on bug1236852 and find the string is different from the SPEC.
Please refer to the attachment.

Thanks.
Flags: needinfo?(cindylee)
(Reporter)

Comment 4

3 years ago
Created attachment 8714177 [details]
SPEC_Error_browser.png
(Reporter)

Comment 5

3 years ago
Created attachment 8714178 [details]
No connection.jpg

Comment 6

3 years ago
Hi Dan, could you help with it since current string is different with spec, thanks.
Flags: needinfo?(dhuang)

Comment 7

3 years ago
Hi Mike, the network error page should display correctly after Bug 1239955 fixed. So please test again when Bug 1239955 landed, Thanks.
Flags: needinfo?(dhuang)

Updated

3 years ago
Depends on: 1239955

Comment 8

2 years ago
Hi Cindy, please help to verify this issue again since bug 1239955 is fixed
Flags: needinfo?(cindylee)
(Reporter)

Comment 9

2 years ago
(In reply to Mike Lien[:mlien] from comment #8)
> Hi Cindy, please help to verify this issue again since bug 1239955 is fixed
Hi Mike,

The string is still incorrect on both v2.5 and v2.6.
Now the string is "Server not found" when there is no network connection.
[Build Info]
TV 2.6 simulator
gaia:
https://github.com/mozilla-b2g/gaia/commit/d9faad5c0f14fcd42f920c9104f0638f46a48b2a
gecko:
https://hg.mozilla.org/mozilla-central/rev/789a12291942763bc1e3a89f97e0b82dc1c9d00b

[Build Info]
TV 2.5 simulator
gaia:
https://github.com/mozilla-b2g/gaia/commit/70c4f38bb88ded00c38f9b4cabe6417969bec6f0
gecko:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/c6ff905771151fd458b92a6d9827a85c4710d4c7
mulet:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/9d519d3bedacb7f5ce467f4c6bef7ff55ff3b0f3
Flags: needinfo?(cindylee)

Comment 10

2 years ago
Hi Dan, please help to check it, thanks. It still show different string from current build.
Flags: needinfo?(dhuang)
Hi Mike,

After confirm with Kershaw Chang, we needs to enable build preference to support geko update.
Bug 1250815 is for the fix.
Flags: needinfo?(dhuang)

Updated

2 years ago
Depends on: 1250815

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1253488
You need to log in before you can comment on or make changes to this bug.