Audio Files Sound Strange on Firefox Platform?

RESOLVED DUPLICATE of bug 1247138

Status

()

Core
Audio/Video: Playback
P1
normal
RESOLVED DUPLICATE of bug 1247138
2 years ago
2 years ago

People

(Reporter: Jackie, Unassigned)

Tracking

({compat})

44 Branch
compat
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.81 Safari/537.36

Steps to reproduce:

https://d396qusza40orc.cloudfront.net/hy/audio1-2exercise2-2%20%28mp3cut.net%29.mp3

When ^ audio file is in a chrome or safari browser, sound plays normally (try replicating this); But on firefox, the sound file sounds distorted, with a lower pitch and slower pronunciation. 

For other audio files, the clip is just not playing at all on firefox but performs normally on Chrome and Safari:

https://d396qusza40orc.cloudfront.net/hy/audio1-2exercise1-1%20%28mp3cut.net%29.mp3



Actual results:

Sound files become distorted, elongated


Expected results:

Normal sound files

Updated

2 years ago
Component: Audio/Video → Audio/Video: Playback
On my windows 7 box, in Nightly, the first link won't play (sounds ok in Chrome); the second plays fine (and sounds the same in Chrome).  

My suspicion (unfounded) is that the mp3 has some errors in it, and whatever in the platform we use to decode doesn't like it (while Chrome probably builds in mp3 and pays the royalty).

Updated

2 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

2 years ago
So is there anything that can be done to fix this issue? Also super weird question, but are you at the Firefox office in Mountain View?
Keywords: compat
Priority: -- → P1
(In reply to Jackie from comment #2)
> So is there anything that can be done to fix this issue? Also super weird
> question, but are you at the Firefox office in Mountain View?

No.
(Reporter)

Comment 4

2 years ago
Haha, sorry I know it was a weird question. My office is located next door to the MV Firefox office. So it would have been funny if this issue was being troubleshot next door. Please let me know if there's anything else you need from my side before this issue might be resolved?
(In reply to Jackie from comment #4)
> Haha, sorry I know it was a weird question. My office is located next door
> to the MV Firefox office. So it would have been funny if this issue was
> being troubleshot next door. Please let me know if there's anything else you
> need from my side before this issue might be resolved?

Anyone likely to fix the issue is in the antipodes.
Which version of Firefox did you use?
Please try again in 44 because things have changed there.

I can't reproduce in Nightly nor Developer Edition (46).
First link doesn't play
ffplay reports
[mp3 @ 0x7fd249004800] Header missing
[mp3 @ 0x7fd249004800] invalid new backstep

and the decoder:
[mp3 @ 0x11a151200] big_values too big
[mp3 @ 0x11a151200] Error while decoding MPEG audio frame.

Note that in Firefox 44 and later, we changed the MP3 player to use a new common MP3 demuxer. I'm guessing the old Apple MP3 decoder had issues with those.

Now neither FFmpeg nor Apple CoreMedia can decode the mp3.
Eugen, is this something you could look into with what's wrong with this mp3?

second link plays well. on all machines tried.
anything particular about the first mp3?
Flags: needinfo?(esawin)
The first MP3 has a varying sample rate (44100 in first frame, 48000 in the rest) which we don't support.

The demuxer rejects the frames due to failed consistency check (VerifyFrameConsistency).
Disabling the check, we would get the reported distorted sound (48000 frames decoded at 44100).
Flags: needinfo?(esawin)
Thanks.. I will make this a dupe of supporting audio configuration change then.

Seeing that audio #2 works just fine.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1247138
You need to log in before you can comment on or make changes to this bug.