Closed Bug 1244212 Opened 5 years ago Closed 5 years ago

firefox ignores fontconfig font family preferences since 44.0

Categories

(Core :: Graphics: Text, defect)

44 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1243194

People

(Reporter: zl29ah, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [gfx-noted])

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160129184854

Steps to reproduce:

exerpt from ~/.config/fontconfig/fonts.conf:

	<match>
		<test name="prgname" compare="eq" qual="any">
			<string>firefox</string>
		</test>
		<test name="family" compare="not_eq" qual="all">
			<string>hackpad</string>
		</test>
		<test name="family" compare="not_eq" qual="all">
			<string>FontAwesome</string>
		</test>
		<edit name="family" mode="prepend_first" binding="strong">
			<string>Terminus</string>
			<string>Fixed</string>
		</edit>
	</match>


Actual results:

random vector fonts everywhere


Expected results:

nice terminus everywhere
Okay, https://bugzilla.mozilla.org/show_bug.cgi?id=1180560 seems relevant as setting gfx.font_rendering.fontconfig.fontlist.enabled to false fixed the issue.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1243073
Not a dupe of bug 1243073, that's about Firefox failing altogether on systems with an old fontconfig version.

(In reply to zl29ah from comment #0)
> Expected results:
> 
> nice terminus everywhere

What kind of font is this "terminus" ... bitmap? truetype? postscript? ...?
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
(In reply to Jonathan Kew (:jfkthame) from comment #3)
> What kind of font is this "terminus" ... bitmap? truetype? postscript? ...?

bitmap pcf
(In reply to zl29ah from comment #4)
> (In reply to Jonathan Kew (:jfkthame) from comment #3)
> > What kind of font is this "terminus" ... bitmap? truetype? postscript? ...?
> 
> bitmap pcf

OK, that explains why you're seeing problems -- the new backend no longer supports PCF bitmap fonts, as indicated in bug 1056479 comment 13.

:jtd, :karlt, should we reconsider that? If not, should the change be highlighted in notes somewhere?
Flags: needinfo?(karlt)
Flags: needinfo?(jd.bugzilla)
Component: Untriaged → Graphics: Text
Keywords: regression
Product: Firefox → Core
Hm, after reading through this issue it seems this could very well be strongly related to a bug I filed a while back, see bug 1243194. The issue/comment liked above about removal of PCF fonts would cause the issue that I noted.
Blocks: 1180560
Whiteboard: [gfx-noted]
I guess this could be the same issue as bug 1243226?

zl29ah, could you test whether this issue still exists on Nightly?
Flags: needinfo?(zl29ah)
Duplicate of this bug: 1244654
(In reply to Xidorn Quan [:xidorn] (UTC+10) (less responsive until Feb 22) from comment #7)
> I guess this could be the same issue as bug 1243226?
> 
> zl29ah, could you test whether this issue still exists on Nightly?

No, with the new fontconfig backend we only handle scalable fonts, which excludes the bitmap font Terminus.

> :jtd, :karlt, should we reconsider that? If not, should the change be highlighted in notes somewhere?

We could add a special mode to fallback to some form of direct fontconfig lookup for families containing bitmap fonts. But I'm not sure it's worth the effort.
Flags: needinfo?(jd.bugzilla)
(In reply to Jonathan Kew (:jfkthame) from comment #5)
> :jtd, :karlt, should we reconsider that? If not, should the change be
> highlighted in notes somewhere?

The release notes mentioned "font matching under Linux now uses the same font matching code as other platforms".  I don't know whether going into the details of differences is necessary in the release notes.  A link to the bug that made the changes, if there is no better place to link may be helpful.  If other platforms and browsers don't support fixed-size fonts, then it is hard to make a case for this on Linux.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Flags: needinfo?(zl29ah)
Flags: needinfo?(karlt)
Resolution: --- → DUPLICATE
Duplicate of bug: 1243194
You need to log in before you can comment on or make changes to this bug.