history dropmarker keep place and cover the content of urlbar while it has disappeared

NEW
Unassigned

Status

()

defect
P3
normal
3 years ago
2 years ago

People

(Reporter: jidanni, Unassigned)

Tracking

({regression, ux-consistency, ux-implementation-level})

43 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox49 wontfix, firefox-esr45 wontfix, firefox50 wontfix, firefox51 fix-optional, firefox52 fix-optional, firefox53 fix-optional)

Details

(Whiteboard: [fxsearch], )

Attachments

(1 attachment)

Reporter

Description

3 years ago
Posted image r.jpg
User Agent: Mozilla/5.0 (X11; Linux i686; rv:45.0) Gecko/20100101 Firefox/45.0 Iceweasel/45.0a2
Build ID: 20160107004004

Steps to reproduce:

Browse a long local filename in a narrow firefox.
Move the pointer out of the window.



Actual results:

One sees html become ht.


Expected results:

The V arrow that one sees occupying that space disappears if the pointer is out of the window. It should not disappear.
Component: Untriaged → Location Bar

Updated

3 years ago
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: long filename cut off if mouse is outside window → history dropmarker keep place and cover the content of urlbar while it has disappeared

Updated

3 years ago
Depends on: 1212482
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1212482

Comment 2

3 years ago
>>>   My Info:   Win7_64, Nightly 47, 32bit, ID 20160222030212
Bug 1212482 is marked as fixed, but I still reproduce this bug using STR in comment 0 and this url:

data:text/html,<script>var S='T_'; for (i=0;i<9;i++) S+=S; location.hash=S;</script>
Blocks: 1203494
Status: RESOLVED → REOPENED
Keywords: regression
Resolution: DUPLICATE → ---
Severity: trivial → normal
Status: REOPENED → NEW
Flags: needinfo?(jaws)
Yeah, the patch in bug 1212482 didn't fix this the right way. I don't have time to work on this right now though.
Flags: needinfo?(jaws)

Updated

3 years ago
Priority: -- → P3
Whiteboard: [fxsearch]
Too late for 49. We could still take a patch for this, but it looks like a fairly minor issue so we would not block the 50 release for it.
fix-optional; would be nice if someone eventually gets to it, but doesn't sound critical or important
You need to log in before you can comment on or make changes to this bug.