Only show URL bar dropmarker on hover

VERIFIED FIXED in Firefox 43

Status

()

defect
VERIFIED FIXED
4 years ago
2 years ago

People

(Reporter: phlsa, Assigned: jaws)

Tracking

(Depends on 3 bugs)

Trunk
Firefox 43
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox43 verified)

Details

(Whiteboard: [qx])

Attachments

(2 attachments)

To further clean up our toolbar a bit, we should make the dropmarker in the URL bar only visible when the URL bar is being hovered.

This actually involves two components:
1) Changing the style of the dropmarker to change its opacity. I've experimented with these transition parameters and they looked pretty good:
transition: opacity 0.15s ease;

2) The dropmarker needs to be the leftmost item of the buttons in that area. That means that it needs to switch place with the box that contains the reader view icon.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
(In reply to Philipp Sackl [:phlsa] (Firefox UX) please use needinfo from comment #0)
> To further clean up our toolbar a bit, we should make the dropmarker in the
> URL bar only visible when the URL bar is being hovered.
> 
> This actually involves two components:
> 1) Changing the style of the dropmarker to change its opacity. I've
> experimented with these transition parameters and they looked pretty good:
> transition: opacity 0.15s ease;
> 
> 2) The dropmarker needs to be the leftmost item of the buttons in that area.
> That means that it needs to switch place with the box that contains the
> reader view icon.

I think it may also be a good idea to hide the splitter between the dropdown and the refresh button when the dropdown is hidden. What do you think?
Flags: needinfo?(philipp)
We would want to keep the splitter if the reader mode or popup-blocked icon are visible though.
Comment on attachment 8660907 [details] [diff] [review]
Patch

> .urlbar-history-dropmarker {
>   -moz-appearance: toolbarbutton-dropdown;
>+  opacity: 0;
>+  transition: opacity 0.15s ease;
>+}

Remove opacity: 0; here.

>+#urlbar:hover > .urlbar-textbox-container > .urlbar-history-dropmarker {
>+  opacity: 1;
> }

And replace this rule with this:

#urlbar:not(:hover) > .urlbar-textbox-container > .urlbar-history-dropmarker {
  opacity: 0;
}
Attachment #8660907 - Flags: review?(dao) → review+
Late comment (new bug?), but since philipp is already flagged here...

Why not just get of the droparrow entirely?

Chrome, Safari, and Edge all lack a droparrow in the URL bar, only IE still has it (and I would not hold it up as a paragon of fresh UI design ;). Not do the search boxes on major sites like Google/Yahoo/Bing/Amazon/DDG. So I'm not sure it's really adding much value in modern UI.


(In reply to (Mostly away 9/11-9/23) Jared Wein [:jaws] (please needinfo? me) from comment #3)
> We would want to keep the splitter if the reader mode or popup-blocked icon
> are visible though.

We should probably move the popup-blocked icon to the newer style of permissions stuff, especially now that Control Center is making this all better. But there isn't a better home for the reader mode icon, and other 3rd-party addon icons probably end up here too...
https://hg.mozilla.org/mozilla-central/rev/f76ad9b2ec28
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
(In reply to (Mostly away 9/11-9/23) Jared Wein [:jaws] (please needinfo? me) from comment #2)
> I think it may also be a good idea to hide the splitter between the dropdown
> and the refresh button when the dropdown is hidden. What do you think?

Deferring that one to Stephen. I think it looks alright either way…


(In reply to Justin Dolske [:Dolske] from comment #6)
> Late comment (new bug?), but since philipp is already flagged here...
> 
> Why not just get of the droparrow entirely?

I remember people talking about facing a lot of opposition to that. Only showing it on hover seemed like an improvement that wouldn't lead to a huge debate to me :)
I'm open to removing it entirely though, which should be a separate bug.


> We should probably move the popup-blocked icon to the newer style of
> permissions stuff, especially now that Control Center is making this all
> better. But there isn't a better home for the reader mode icon, and other
> 3rd-party addon icons probably end up here too...

I think the popup blocked thing is going away with the latest developments of control center (shown in the ID-block instead)
Flags: needinfo?(philipp) → needinfo?(shorlander)
(In reply to Philipp Sackl [:phlsa] (Firefox UX) please use needinfo from comment #8)
> > We should probably move the popup-blocked icon to the newer style of
> > permissions stuff, especially now that Control Center is making this all
> > better. But there isn't a better home for the reader mode icon, and other
> > 3rd-party addon icons probably end up here too...
> 
> I think the popup blocked thing is going away with the latest developments
> of control center (shown in the ID-block instead)

I believe that is the current plan.
Flags: needinfo?(shorlander)
Posted image Screenshot
The white space (please see the screenshot) looks strange now after pressing CMD-L.
(In reply to Mehmet Sahin from comment #10)
> Created attachment 8670439 [details]
> Screenshot
> 
> The white space (please see the screenshot) looks strange now after pressing
> CMD-L.

Mehmet, can you please file a new bug for this? Thanks for posting here, it will be good to get a new bug on file for that (I usually ask other people to file the bug so that they can get experience filing bugs :) ).
Flags: needinfo?(mehmet.sahin)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #11)
> (In reply to Mehmet Sahin from comment #10)
> > Created attachment 8670439 [details]
> > Screenshot
> > 
> > The white space (please see the screenshot) looks strange now after pressing
> > CMD-L.
> 
> Mehmet, can you please file a new bug for this? Thanks for posting here, it
> will be good to get a new bug on file for that (I usually ask other people
> to file the bug so that they can get experience filing bugs :) ).

Done: Bug 1212482
Flags: needinfo?(mehmet.sahin)
Depends on: 1221514
I have reproduced this bug on Nightly 43.0a1 (2015-09-10) on ubuntu 14.04 LTS, 32 bit!

The bug's fix is now verified on Latest Beta 43.0b1!

Build ID: 20151103023037
User Agent: Mozilla/5.0 (X11; Linux i686; rv:43.0) Gecko/20100101 Firefox/43.0

[bugday-20151104]
Reproduced the bug on firefox nightly 43.0a1 (2015-09-10) on windows 10 x64

Verified as fixed with latest firefox beta 43.0b7 (Build ID: 20151126120800)

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0

As it is also verified on Linux (Comment 13), Marking it as verified!
Status: RESOLVED → VERIFIED
QA Whiteboard: [testday-20151127]
Depends on: 1238637
Depends on: 1244420
Depends on: 1327022
Depends on: 1327131
You need to log in before you can comment on or make changes to this bug.