[e10s][APZ] dragging the scrollbar doesn't follow the mouse movements and page moves up and down

RESOLVED FIXED in Firefox 47

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: alice0775, Assigned: kats)

Tracking

({regression, reproducible})

47 Branch
mozilla47
regression, reproducible
Points:
---

Firefox Tracking Flags

(e10s?, firefox46 unaffected, firefox47 fixed)

Details

(Reporter)

Description

3 years ago
See mozillazine post : http://forums.mozillazine.org/viewtopic.php?p=14496365#p14496365

Nightly 31-01-16, STR:
Create new profile, launch Nightly, make sure e10s and APZ are enabled, open new tab, go to https://wiki.mozilla.org/Electrolysis and https://wiki.mozilla.org/Electrolysis. For some reason the scrollbar doesn't follow the mouse movements and moves up and down. If I try to do the same thing on http://www.gamemag.ru, the scroll goes crazy

Steps To Reproduce:
1. e10s and APZ are enabled
2. Open https://wiki.mozilla.org/Electrolysis
3. https://wiki.mozilla.org/Electrolysis

Actual Results:
the scroll goes crazy.
scrollbar doesn't follow the mouse movements and page moves up and down.

Expected Results:
Not so.

Regression Window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=bdecb787f1a2c12be5f0059afe214868402d2479&tochange=6ccda47f18b38e0a16564a339a0229133191549c

Regressed by: Bug 1242690
Flags: needinfo?(dvander)
Flags: needinfo?(bugmail.mozilla)
Flags: needinfo?(botond)
(Reporter)

Comment 1

3 years ago
Oops,
> 3. https://wiki.mozilla.org/Electrolysis

3. Drag the thumb of scrollbar
Backed out the three patches from bug 1242690 since this seems pretty bad.

https://hg.mozilla.org/integration/mozilla-inbound/rev/a49bae84297c
Assignee: nobody → bugmail.mozilla
Flags: needinfo?(dvander)
Flags: needinfo?(bugmail.mozilla)
Flags: needinfo?(botond)
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1244662

Comment 5

3 years ago
It appears to be fixed in 47.0a1 (2016-02-01).
Thanks. The backout landed on m-c in https://hg.mozilla.org/mozilla-central/rev/a49bae84297c
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox47: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
You need to log in before you can comment on or make changes to this bug.