bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Show bookmarks toolbar when viewing a new tab

RESOLVED WONTFIX

Status

()

Firefox
Toolbars and Customization
--
enhancement
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: Kestrel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Onboarding] )

(Reporter)

Description

3 years ago
In windows that are currently showing a new tab (about:newtab or about:privatebrowsing) the bookmarks toolbar should be displayed.

1. Improves visibility of the bookmarks toolbar.
2. Shows bookmarks toolbar only when it is most needed.
3. Keeps browser chrome to a minimum.
4. Easier access without having to manually open and close the bookmarks toolbar each time.
5. Makes new tabs more useful when they are blanked or in private browsing mode.

For all other pages the bookmarks toolbar is displayed normally according to user preference.
(Reporter)

Updated

3 years ago
Blocks: 1219810
Whiteboard: [Onboarding]
I don't think I agree, we can't know if the user has anything useful on the toolbar.
While this may work for Google Chrome, I don't think it works as well for Firefox for two reasons:
1) Google Chrome has done this since day 1, so users may already have workflows that incorporate this
2) We default new bookmarks to the "Unsorted Bookmarks" folder, and not the bookmarks toolbar.

Users who haven't been using the Bookmarks Toolbar will undoubtedly have bookmarks that are old and crusty there so it wouldn't be of much value.

I could see this being useful for people who already were using the bookmarks toolbar, but I'm not sure how we could expose it to those users: "Only show the Bookmarks Toolbar on the New Tab page"
Good point, it's a workflow bound to having bookmarks go to the toolbar by default. I'd be prone to wontfix.
Thanks for filing. It's a good idea, but I think without a major overhaul of how bookmarks are created, as well as a transition plan for existing users, this is basically considered 'wontfix'.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 5

3 years ago
I can appreciate the desire to only show relevant and useful information, showing old irrelevant bookmarks is definitely a problem but should be limited to the short term. As a side note the way the toolbar fills causes this to occur anyway, with oldest bookmarks most visible and newest overflowing. 

The toolbar not being the default save location means the user has to actively put something useful in it (but also makes it more curatable), this is another short term problem as the greater visibility and accessibility should encourage greater use.

If the toolbar still goes unused then it wastes some vertical space on the new tab page but this is a relatively small sacrifice given the benefits. It doesn't get in the way anywhere else and can be disabled completely by changing the new tab page.

(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #2)
> "Only show the Bookmarks Toolbar on the New Tab page"

Should be

>"Always show the Bookmarks Toolbar on the New Tab page"
I agree these could be short term problems. If we do decide to do this, we should do the other things you mention: 1) move default bookmark placement to the bookmarks toolbar, and 2) insert new items at the beginning instead of the end
You need to log in before you can comment on or make changes to this bug.