Closed Bug 727668 Opened 9 years ago Closed 6 months ago

Show bookmarks from the bookmarks toolbar in the new tab page

Categories

(Firefox :: New Tab Page, enhancement, P3)

enhancement

Tracking

()

VERIFIED FIXED
84 Branch
Tracking Status
firefox84 --- verified

People

(Reporter: dcamp, Assigned: jaws)

References

(Depends on 2 open bugs, Blocks 2 open bugs, Regressed 1 open bug)

Details

Attachments

(3 files, 1 obsolete file)

Chrome shows a stand-in for the bookmarks toolbar in its new tab page when the bookmarks toolbar is hidden.  It's useful.
Could be part of new/home tab merge/redesign.
Severity: normal → enhancement
OS: Mac OS X → All
Hardware: x86 → All
Version: 10 Branch → unspecified
Mass-move to Firefox::New Tab Page.

Filter on new-tab-page-component.
Component: General → New Tab Page
For those waiting for this feature, I created an add-on to replace the new tab page with bookmarks: https://addons.mozilla.org/en-US/firefox/addon/new-tab-bookmarks/.

The benefit of this feature is the ability to keep save vertical space while still allowing easy access to the bookmarks. Since getting used to Chrome's inclusion of bookmarks in the new tab page, it became a big part of my workflow. Apart from using autocomplete in the URL bar, I'm constantly opening a new tab to click on a bookmark.
Duplicate of this bug: 1408087
Duplicate of this bug: 1400650
Here's a take on bookmark bar in new tab page in the form of an addon. Feedback/thoughts welcome
https://addons.mozilla.org/en-US/firefox/addon/ephemeral-bookmark-bar
Any progress?

@code-ant, your extension is closed-source and needs a lot of permissions.
Duplicate of this bug: 1546290

+1

Frankly, this feature is the only reason that keeps me using Google Chrome.

Priority: -- → P3
Duplicate of this bug: 1244649
Duplicate of this bug: 1589008

This bug clearly improves the UX of new tab page particularly on devices with small screens like laptops and netbooks. Please make this a priority

Saw another add-on recommended for this (that replaces the default new tab page): https://addons.mozilla.org/firefox/addon/new2tab/

Duplicate of this bug: 1653522

Showing and hiding the Bookmarks Bar can be accomplished using the userChrome.css file but there are a lot of disadvantages to doing it that way. Having a setting would be far easier.

Disadvantages:
(1) Takes a lot of steps to enable. For example: https://www.userchrome.org/how-create-userchrome-css.html
(2) CSS solutions often break between Firefox versions.
(3) userChrome.css isn't synced, which means the steps need to be performed on every computer.

Assignee: nobody → jaws
Status: NEW → ASSIGNED

This adds the ability to force the bookmarks toolbar to appear on all pages. The checkbox in the toolbar context menu will reflect if the toolbar will appear outside of the newtab page. The toolbar will always appear on the newtab page. Profiles that already had the toolbar showing will have a migration to keep their experience unchanged.

Blocks: 1665353
Depends on: 1666302
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bd318d959528
Show bookmarks toolbar on the new tab page. r=Gijs

(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #16)

Created attachment 9173784 [details]
Bug 727668 - Show bookmarks toolbar on the new tab page.

This adds the ability to force the bookmarks toolbar to appear on all pages. The checkbox in the toolbar context menu will reflect if the toolbar will appear outside of the newtab page. The toolbar will always appear on the newtab page. Profiles that already had the toolbar showing will have a migration to keep their experience unchanged.

Just curious-- in the comments you added to firefox.js (starting at line 1.12) you mentioned the fact that the bookmarks toolbar can also be toggled with a keyboard shortcut. Is this something you've added with this bug? I'm on the latest version of Release (MacOS) and currently do not have this ability available by default.

"
+pref("browser.toolbars.bookmarks.persist_open", false);
+// When true, this pref will always show the bookmarks bar on
+// the New Tab Page, allowing showing/hiding via keyboard shortcut,
"

Backout by malexandru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3c17e3309eac
Backed out changeset bd318d959528 for causing multiple failures

(In reply to danmattera1 from comment #18)

Just curious-- in the comments you added to firefox.js (starting at line 1.12) you mentioned the fact that the bookmarks toolbar can also be toggled with a keyboard shortcut. Is this something you've added with this bug? I'm on the latest version of Release (MacOS) and currently do not have this ability available by default.

See bug 1328637.

Flags: needinfo?(jaws)

It looks like the two tests on line numbers 6565 and 3969 make an incorrect assumption that resize events should not be fired on new tab page? Am I correct that this assumption should no longer hold?

Flags: needinfo?(jaws)

(In reply to Savvy Raghuvanshi from comment #24)

It looks like the two tests on line numbers 6565 and 3969 make an incorrect assumption that resize events should not be fired on new tab page? Am I correct that this assumption should no longer hold?

No, the assumption should still hold. I believe that the resize test failure was unrelated and potentially an intermittent test failure. The failure related to "3969" is a performance test that checks to see we are not making any unexpected UI changes upon opening new tabs. That test failed because I hadn't updated the expected behavior now that the toolbar will appear in a new tab.

Flags: needinfo?(jaws)
No longer depends on: 1666302
Duplicate of this bug: 1666302
Attachment #9180775 - Attachment description: Bug 727668 - Add an options to show the toolbar on the new tab page, always, or never. → Bug 727668 - Add options to show the toolbar on the new tab page, always, or never.
Attachment #9180775 - Attachment description: Bug 727668 - Add options to show the toolbar on the new tab page, always, or never. → Bug 727668 - Add an options to show the toolbar on the new tab page, always, or never.
Attachment #9180775 - Attachment is obsolete: true
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5b6a14b4e16e
Show bookmarks toolbar on the new tab page. r=Gijs,fluent-reviewers
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ba261cf25651
Show bookmarks toolbar on the new tab page. r=Gijs,fluent-reviewers
Flags: needinfo?(jaws)

Henrik, can you help me out here? I don't know why these tests would fail. Do screenshots or some other fixed asset need updating?

Flags: needinfo?(jaws) → needinfo?(hskupin)

Given that this is a perma failure I assume you can also reproduce it locally? If yes, would you mind running the specific Marionette test with the following option so that we can see the screenshot data not truncated:

./mach marionette-test -vv --gecko-log - --setpref="marionette.log.truncate=false" testing/marionette/harness/marionette_harness/tests/unit/test_screenshot.py

Note that I haven't seen the new UI yet, so I cannot say how it would look like and how it actually affects the screenshot feature of Marionette. Interesting is that we have the new tab page turned off when running Marionette tests, and as I read this feature is for that page only. So it would help a lot to actually see the screenshots as created by Marionette.

Note that given by the WebDriver spec the boundaries for the screenshot are defined by the document's element rectangle of the top-level browsing context.

Flags: needinfo?(hskupin)
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/45bbeabb0c89
Show bookmarks toolbar on the new tab page. r=Gijs,fluent-reviewers,marionette-reviewers,whimboo
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch
Regressions: 1673341
Regressions: 1673369
Depends on: 1673402
Depends on: 1673403
Depends on: 1673422
Depends on: 1673363
Depends on: 1673490

Is there any way to disable this behavior? I've disabled the bookmarks toolbar years ago because I never use it, but now I'm getting some old synced bookmarks toolbar popping up on every new tab! Is my only resolution to manually delete all items from the bar? I get that some people want this -- there's plenty of +1's in this thread -- but I've purposely removed the bookmarks toolbar because it's (for me) clutter.

I see this setting in about:config: browser.toolbars.bookmarks.visibility, with the current value "newtab". However, changing this value seems to have no effect. I've tried "none" and "false".

I had lost all hope of seeing this in an official release, so I made an extension to manage bookmarks in the new tab page: https://addons.mozilla.org/firefox/addon/umibo/
it can show bookmarks from the Toolbar, Other, Menu and Mobile folders, and has a field for additional CSS rules.

(In reply to Davyd McColl from comment #37)

Is there any way to disable this behavior?
Right click on the toolbar -> Bookmarks Toolbar -> Never

Is there any way to disable this behavior?

Right click on the toolbar -> Bookmarks Toolbar -> Never

or just use never in browser.toolbars.bookmarks.visibility.


No better is use integer:

  • 0 - "never",
  • 1 - "newtab",
  • 2 - "always"

?

Depends on: 1673566
Depends on: 1672792

:jaws - can you show the UI of what this looks like? It looks like this bookmarks toolbar is off by default in Release, but is the plan to have it on by default (for only new tab?) in Fx 84?

Flags: needinfo?(jaws)

Yes, the toolbar is off by default in Release 82. In Firefox 82 the toolbar will get enabled if:

  • bookmarks are imported to the toolbar
  • a user saves a bookmark to the toolbar
  • a user manually enables the toolbar through one of the various toolbar menus

In Firefox 84 the toolbar will be changed to "Only on New Tab" unless the user already had the toolbar visible in which case their setting will now be "Always".

I am attaching a screenshot of the change to the toolbar context menu. Note that this change is also reflected in the View menu seen at the top of the screen on macOS and the "Alt-menu" on Windows. This change is also reflected in Customize mode in the list of toolbars at the bottom of the window.

Flags: needinfo?(jaws)

I have verified this enhancement and I can confirm the following:

  • The "Bookmarks Toolbar" is displayed only on the "New Tab" if the "Only on New Tab" option is checked.
  • The "Bookmarks Toolbar" is displayed on all tabs if the "Always" option is checked.
  • The "Bookmarks Toolbar" is displayed is not displayed at all if the "Never" option is checked.
    Verified using the latest Firefox Nightly (84.0a1 Build ID - 20201029095639) installed on Windows 10 x64, Mac 10.15, and Ubuntu 18.04 x64.
Status: RESOLVED → VERIFIED
Depends on: 1674199
Depends on: 1674083
No longer depends on: 1674083
Depends on: 1674090
Depends on: 1003364
Blocks: 1673369
No longer regressions: 1673369
Depends on: 1675147
Depends on: 1675148
Depends on: 1675143
Depends on: 1675145
Regressions: 1677733
Regressions: 1673357

Perhaps this is it's own feature request, but should this not also show on the home page? Especially if one has it set to blank. It is a minor inconvenience to have to start Firefox and then open a new tab for the bookmarks to show before closing the "home" page tab and navigating away. The behavior of chromium based browsers also includes the bookmarks on the home page.

Duplicate of this bug: 1679562

(In reply to flat from comment #45)

Perhaps this is it's own feature request, but should this not also show on the home page? Especially if one has it set to blank. It is a minor inconvenience to have to start Firefox and then open a new tab for the bookmarks to show before closing the "home" page tab and navigating away. The behavior of chromium based browsers also includes the bookmarks on the home page.

you can find it in the preferences -- home -- new windows and tabs
you could choose to open a specific home page for every new tab or the firefox new tab page

Regressions: 1679728
Depends on: 1676492

(In reply to flat from comment #45)

Perhaps this is it's own feature request, but should this not also show on the home page? Especially if one has it set to blank. It is a minor inconvenience to have to start Firefox and then open a new tab for the bookmarks to show before closing the "home" page tab and navigating away. The behavior of chromium based browsers also includes the bookmarks on the home page.

It'll work (ie the toolbar will show) if you set it to show "Firefox Home" instead of a blank page. We'd like to make it work for blank pages too, but "about:blank" has a lot of other uses (by websites, esp.) and so it's technically more difficult - when we tried initially it broke at least 5 different scenarios (bug 1673363, bug 1675145, bug 1675143, bug 1675148, bug 1675147), so we disabled it for now. Enabling it there is bug 1676492.

Just did a fresh install of FF84 on a new machine and don't see the "Only on New Tab" option. Screenshot of what I'm expecting vs what I'm seeing attached. Is there something I need to do to enable it? Bookmarks are present on the Bookmarks Toolbar.

(In reply to GaryEarthling from comment #50)

Just did a fresh install of FF84 on a new machine and don't see the "Only on New Tab" option. Screenshot of what I'm expecting vs what I'm seeing attached. Is there something I need to do to enable it? Bookmarks are present on the Bookmarks Toolbar.

This is being rolled out slowly on the 84 branch. It's default-on in 85. If you want to opt-in on 84, flip the pref browser.toolbars.bookmarks.2h2020 to true.

Are there plans to roll this out to Firefox on Ubuntu as well? I'm using FF 75 and don't have the option. Tried setting browser.toolbars.bookmarks.2h2020 to true as well but it didn't have any effect. Thanks!

(In reply to GaryEarthling from comment #52)

Are there plans to roll this out to Firefox on Ubuntu as well? I'm using FF 75 and don't have the option. Tried setting browser.toolbars.bookmarks.2h2020 to true as well but it didn't have any effect. Thanks!

Firefox 75 is now a year old and very insecure, so I hope that's some kind of typo...

I don't know really know what version of Ubuntu you're on, but from looking at https://packages.ubuntu.com/search?keywords=firefox&searchon=names&suite=groovy&section=all it would seem that you should be able to get 85, unless you're on a specific architecture where you need to use the ports distributed version? Or perhaps you're on an older LTS version of Ubuntu?

The details of which version of Firefox different Ubuntu versions provide you with via apt and other builtin distro tools is one to take up with canonical, I'm afraid - we have no direct influence over it. Assuming you're on an architecture for which we distribute builds ourselves, you should be able to download the most recent version of Firefox directly from Mozilla at https://www.mozilla.org/firefox/all/ and install that.

(In reply to :Gijs (he/him) from comment #53)

Firefox 75 is now a year old and very insecure, so I hope that's some kind of typo...

Thanks :Gijs. Was on a laptop I hadn't used in a while. Didn't realize it was running an older version of Ubuntu. Updated to the latest release - problem solved. :-)

You need to log in before you can comment on or make changes to this bug.