Closed Bug 1245082 Opened 6 years ago Closed 6 years ago

Incorrect interface font used in Fedora 23 when "Open Sans" is selected.

Categories

(Core :: Graphics: Text, defect)

41 Branch
Unspecified
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1245811

People

(Reporter: mail, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160126084239

Steps to reproduce:

1) Installed Fedora 23 in a VM
2) Installed Open Sans font
3) In gnome-tweak-tool, I changed the interface font to Open Sans
4) I opened the Firefox installed by default and it is correct
5) Upgraded firefox to 44 (both from the repo, and manually from mozilla.org)
6) I opened Firefox and was confronted with the comfortaa font instead of Open Sans


Actual results:

The interface font was set to Comfortaa


Expected results:

The interface font should have been Open Sans
I have also submitted the bug to Red Hat as I cannot currently be sure if the bug is specifically in Firefox, or if it is in Fedora.

https://bugzilla.redhat.com/show_bug.cgi?id=1303585
Component: Untriaged → Graphics: Text
Product: Firefox → Core
Can you find a regression window using mozregression (http://mozilla.github.io/mozregression/)?
Flags: needinfo?(mail)
Found it,  though it appears to be considerably earlier than I would have expected, seeing as it didn't appear in Fedora until Firefox 44.

 3:13.76 LOG: MainThread Bisector INFO Last good revision: 3cfde06d952aafa82f9ba248e1b5493f2aa5900e
 3:13.76 LOG: MainThread Bisector INFO First bad revision: d6d25651b082b10c8bffea72e4fe5136e04c7da1
 3:13.76 LOG: MainThread Bisector INFO Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=3cfde06d952aafa82f9ba248e1b5493f2aa5900e&tochange=d6d25651b082b10c8bffea72e4fe5136e04c7da1

 3:14.67 LOG: MainThread main INFO Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1056479
Flags: needinfo?(mail)
Blocks: 1056479
Version: 44 Branch → 41 Branch
OS: Unspecified → Linux
Flags: needinfo?(jd.bugzilla)
Possibly similar to bug 1245811, where it appears that fontconfig alias entries with the <prefer> type are causing the new linux fontlist code to fail to find the intended font family?
That looks to be correct. After renaming /etc/fonts/conf.d/60-open-sans.conf to /etc/fonts/conf.d/60-open-sans.conf.bak, reloading Firefox correctly showed open sans. The contents of the file are as below, and it looks like it's picking up on the <prefer>sans-serif</prefer>


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE fontconfig SYSTEM "../fonts.dtd">
<fontconfig>
 <alias>
    <family>Open Sans</family>
    <prefer>
      <family>sans-serif</family>
    </prefer>
  </alias>
  <alias>
    <family>sans-serif</family>
    <default>
      <family>Open Sans</family>
    </default>
  </alias>
</fontconfig>


I am happy for you to close this bug, and I will add myself to the watch list of the other.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(jd.bugzilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1245811
(In reply to Matthew Ames from comment #3)
> Found it,  though it appears to be considerably earlier than I would have
> expected, seeing as it didn't appear in Fedora until Firefox 44.

FWIW, that makes sense; although the code landed earlier, it wasn't turned on by default on the release channel until FF44 (in bug 1180560).
No longer blocks: 1056479
You need to log in before you can comment on or make changes to this bug.