Closed Bug 1245335 Opened 5 years ago Closed 5 years ago

Unable to bisect recent Firefox for Android builds

Categories

(Testing :: mozregression, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kbrosnan, Assigned: parkouss)

References

Details

Attachments

(1 file)

Running mozregression 2.2.0

mozregression --app fennec --good 2016-01-30 --bad 2016-02-01
 0:00.88 LOG: Thread-1 Bisector WARNING Skipping build 2016-01-30: Unable to find build info for 2016-01-30
 0:00.97 LOG: Thread-3 Bisector WARNING Skipping build 2016-02-01: Unable to find build info for 2016-02-01
 0:00.97 LOG: Thread-2 Bisector WARNING Skipping build 2016-01-31: Unable to find build info for 2016-01-31

API 15 work might have changed the file names? bug 1155801 and bug 1219094
Yes just looked at the archive and the folder names changed on the 29th. https://ftp.mozilla.org/pub/mobile/nightly/2016/01/2016-01-29-03-02-06-mozilla-central-android-api-15/ for example.
Fallout from Bug 1219094.
Depends on: 1219094
Thanks for the investigation - I'm looking at it.
So, Kevin is right, this changed on 2016-01-29 for archive.m.o too:

https://archive.mozilla.org/pub/mobile/nightly/2016/01/

We also have an issue with taskcluster, for the same reason - api-11 was replaced by api-15 on mozilla-central. No luck, mozilla-inbound still have both:

https://tools.taskcluster.net/index/#gecko.v2.mozilla-inbound.latest.mobile/gecko.v2.mozilla-inbound.latest.mobile

So I am not sure what is the right thing to do for that. I found that if I use api-15 for a push timestamp >= 1454027413 (roughly 2016-01-29 00:35:50) this makes things work on m-c, and on m-i. So that mean that pushes before this date will use api-11, and api-15 after (for every branches).

I will apply that logic, unless someone see any error in the reasoning.

One other thing, we still have fennec-23 registered as a possible mozregression application. Roughly:

fennec-23 is for android-api-9 and older android-api
fennec is for android-api-11 and now android-api-15

Does that make sense ? (I am not really qualified to judge that :)) Do we still want to support fennec-23 ?
Assignee: nobody → j.parkouss
Status: NEW → ASSIGNED
Attachment #8715218 - Flags: review?(wlachance)
Monday should be fine. The regression that I thought had started in that time actually was older.
Comment on attachment 8715218 [details] [review]
use api-15 for fennec starting from 2016-01-29

This all makes sense, ship it!
Attachment #8715218 - Flags: review?(wlachance) → review+
Landed in https://github.com/mozilla/mozregression/commit/3fbd0421611a5f5816c7c50f4692a69c20d956c3.

I will do a release later today.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Does bug 1246844 block mozregression from working on Android? Can you lock the version of mozdevice to one before the root requirement?
(In reply to Kevin Brosnan [:kbrosnan] from comment #9)
> Does bug 1246844 block mozregression from working on Android? Can you lock
> the version of mozdevice to one before the root requirement?

No, it should work as usual - the bug is here so we can try to leverage the use of root in the adb calls.
You need to log in before you can comment on or make changes to this bug.