Closed Bug 1245431 Opened 9 years ago Closed 4 months ago

Add display:table support to details

Categories

(Core :: Layout, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1856374
Tracking Status
firefox47 --- affected

People

(Reporter: TYLin, Unassigned)

References

(Blocks 1 open bug)

Details

Per bug 591737 comment 235, add display:table support to details.

  <details style="display: table">
    <summary style="display: table-cell"></summary>
    <div style="display: table-cell"></div>
  </details>
No longer depends on: 1245430
Severity: normal → S3

Looks like we took care of this in bug 1856374 (still behind a pref for now). --> Duping.

With the pref flipped, I double-checked that markup like in comment 0 does produce a frame dump with a TableWrapper as the outermost frame for the details element, like so:

Block(body)(1)@7f29f9b18a20 parent=7f29f9b18958 (x=480, y=480, w=60480, h=1140) [content=7f29f840c040] [cs=7f29f9b9b008] <
  line@7f29f9b19278 count=1 state=block,clean,prevmarginclean,not-impacted,not-wrapped,no-break,clear-before:none,clear-after:none(x=0, y=0, w=2186, h=1140) <
    TableWrapper(details)(0)@7f29f9b18b38 parent=7f29f9b18a20 (x=0, y=0, w=2186, h=1140) [content=7f29f840c430] [cs=7f29fce06608:-moz-table-wrapper] <
      Table(details)(0)@7f29f9b18be8 parent=7f29f9b18b38 (x=0, y=0, w=2186, h=1140) [content=7f29f840c430] [cs=7f29f9b9bf08] <
        TableRowGroup(details)(0)@7f29f9b18d30 parent=7f29f9b18be8 (x=0, y=0, w=2186, h=1140) [content=7f29f840c430] [cs=7f29fce07f08:-moz-table-row-group] <
          TableRow(details)(0)@7f29f9b18dd8 parent=7f29f9b18d30 (x=0, y=0, w=2186, h=1140) [content=7f29f840c430] [cs=7f29fce95208:-moz-table-row] <
            TableCell(summary)(1)@7f29f9b18e98 parent=7f29f9b18dd8 (x=0, y=0, w=2186, h=1140) [content=7f29f840c550] [cs=7f29f9b9cd08] <
Status: NEW → RESOLVED
Closed: 4 months ago
Duplicate of bug: 1856374
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.