Closed Bug 1245444 Opened 7 years ago Closed 7 years ago

Missing Pocket, home and downloads buttons if Hello is placed in the menu panel and then restored

Categories

(Firefox :: Toolbars and Customization, defect)

47 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1245447
Tracking Status
firefox44 --- unaffected
firefox45 --- unaffected
firefox46 + unaffected
firefox47 + fixed

People

(Reporter: adalucinet, Unassigned)

References

Details

(Keywords: regression)

Affected versions: latest Nightly 47.0a1 (from 2016-02-02), e10s enabled/disabled
Affected platforms: Ubuntu 14.04 32-bit, Mac OS X 10.9.5 and Windows 7 64-bit

Steps to reproduce:
1. Launch Firefox with a clean profile.
2. Click on Menu panel (Hamburger button).
3. Select Customize.
4. Drag Hello button to the Menu Panel.
5. Click 'Restore Defaults' button.

Expected results: All previous changes are properly restored.
Actual results: Pocket, home and downloads buttons are no longer displayed in the toolbar, Menu Panel nor Additional Tools and Features. 

Additional notes:
1. Via about:config page, 'browser.uiCustomization.state' pref points that the buttons are still placed in the nav-bar: 
'nav-bar': [
      'urlbar-container',
      'search-container',
      'bookmarks-menu-button',
      'pocket-button',
      'downloads-button',
      'home-button',
      'loop-button'
    ],
2. Unaffected version:
* latest Aurora 46.0a2 (from 2016-02-02) - not reproducible maybe because of the extra buttons (Web developer tools, WebIDE) placed in the toolbar?
* 45 beta 2 (Build ID: 20160201143558)
* 44.0RC build 3 (Build ID: 20160123151951).
3. Regression range:
Last good revision: 0c12d4229be0068eb1b9beb5064b800f12143f20
First bad revision: 3ba655f6bc67660a2dcfc4c2a5b3d0d17714f53d
Pushlog: https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=0c12d4229be0068eb1b9beb5064b800f12143f20&tochange=3ba655f6bc67660a2dcfc4c2a5b3d0d17714f53d

Regressed by 3ba655f6bc67 Shane Caraveo — Bug 1215694 move pocket to a system addon
Version: Trunk → 47 Branch
Regression from 46, tracking for 46 and 47. 
Shane can you check on whether this affects 46 or not?
Keywords: regression
Flags: needinfo?(mixedpuppy)
Part of this bug, which affects home/downloads buttons, is caused by the same issue causing bug 1245447.  The second part, the pocket button not being place back into the toolbar, is a limitation of CUI introduced in bug 982656, with consideration for dealing with it in bug 1023319.  I'm going to dup against 1245447.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(mixedpuppy)
Resolution: --- → DUPLICATE
Duplicate of bug: 1245447
You need to log in before you can comment on or make changes to this bug.