Chrome fails to refresh in fullscreen with windowed plugin content

RESOLVED DUPLICATE of bug 1148978

Status

()

Core
Plug-ins
P1
normal
RESOLVED DUPLICATE of bug 1148978
2 years ago
2 years ago

People

(Reporter: tracy, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox47 affected)

Details

(Reporter)

Description

2 years ago
Spinning this off from https://bugzilla.mozilla.org/show_bug.cgi?id=1148978#c28.

STR:

1) in e10s browser, open https://dl.dropboxusercontent.com/u/95157096/85f61cf7/hg9wvl1t6q.swf
2) set view to fullscreen
3) move mouse up to the very top edge of the content then back in and around mouse around near the top of page some.

Tested result:
The chrome of browser toolbars begins to appear in portions in the content.

original posters comment has: See https://dl.dropboxusercontent.com/u/95157096/85f61cf7/xk7o2987qo.mp4 which shows the issue well.

Expected result:
No bleeding of chrome back into the content.

4) return browser to normal size

notice the bleeding of content into toolbars remains to some extent.

I can only reproduce this on Windows. (Flash version 20.0.0.286)
Win 7, Nightly 47.0a1, 20160203030249 - FAIL
Mac 10.9.5, Nightly 47.0a1, 20160204030229 - PASS
Ubuntu 14.04, Nightly 47.0a1, 20160204030229 - PASS
tracking-e10s: --- → ?
I've been speaking with RyanVM about this, and it looks like this issue may be pretty widespread. Ryan found these possibly related bugs from a quick search in bugzilla:

bug 1236369
bug 1238589
bug 1202245
bug 1236152
bug 1232890
I also don't think this is flash related.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows
Hardware: Unspecified → x86
(Reporter)

Comment 3

2 years ago
I am not sure the black artifact bugs (bug 1238589 and bug 1232890) are related.  But the others certainly appear to be related.  There is work being done in bug 1232042.  Let's see if once their fixes stick there if these other reported issues are fixed.  If so, then we can dupe the lot over to bug 1232042.

Updated

2 years ago
Flags: needinfo?(twalker)

Updated

2 years ago
Blocks: 874016

Updated

2 years ago
Depends on: 1232042

Updated

2 years ago
Blocks: 1245994

Updated

2 years ago
Summary: Chrome is revealing itself in full screen of flash content. → Chrome fails to refresh in fullscreen and windowed plugin content

Updated

2 years ago
Summary: Chrome fails to refresh in fullscreen and windowed plugin content → Chrome fails to refresh in fullscreen with windowed plugin content

Updated

2 years ago
Depends on: 1148978
Flags: needinfo?(twalker)
tracking-e10s: ? → +
Priority: -- → P1

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1148978
You need to log in before you can comment on or make changes to this bug.