Mail window cannot be moved/dragged any more.

RESOLVED FIXED in Thunderbird 47.0

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Jorg K (GMT+2), Assigned: Paenglab)

Tracking

({regression})

Trunk
Thunderbird 47.0
x86
Windows
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Left-click onto the menu bar and try to move the window. It doesn't move.

Richard tells me that this is due to
http://hg.mozilla.org/mozilla-central/rev/29dd8f5e46f8
(Assignee)

Comment 1

2 years ago
Created attachment 8716521 [details] [diff] [review]
dragFix.patch

I tested it on all Windows versions and Linux. Jörg, please can you check it to be sure?

Aleth, I moved rules to content. Please check it on OS X to be sure I haven't broken it.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8716521 - Flags: review?(aleth)
Attachment #8716521 - Flags: feedback?(mozilla)
(Assignee)

Comment 2

2 years ago
Oh, I also tested it on Linux.
(Reporter)

Comment 3

2 years ago
Comment on attachment 8716521 [details] [diff] [review]
dragFix.patch

With this patch the main window can be moved again. Thanks!

Without wanting to dive into the details, can you please explain what
+    -moz-window-dragging: no-drag;
is about. I'm just curious.

I'd also like to note the following. Frequently on uplift requests I read:
  Risk to taking this patch (and alternatives if risky): **low, only CSS changes**
Frankly, I never quite believed this, and here is proof that with CSS you can bring the whole system down ;-)
Attachment #8716521 - Flags: feedback?(mozilla) → feedback+
(Assignee)

Comment 4

2 years ago
(In reply to Jorg K - Let the purists rule (GMT+1) from comment #3)
> Comment on attachment 8716521 [details] [diff] [review]
> dragFix.patch
> 
> With this patch the main window can be moved again. Thanks!
> 
> Without wanting to dive into the details, can you please explain what
> +    -moz-window-dragging: no-drag;
> is about. I'm just curious.

Ehwn we are in -moz-windows-compositor case (Vista/Win7 Glass, Win8-10 default theme) then the menubar is below the tabs and looks visually belonging to the main toolbox). Then it would be weird when you can move the window with this toolbar. In all other cases the menubar is above the tabs inside the titlebar which is movable.

> I'd also like to note the following. Frequently on uplift requests I read:
>   Risk to taking this patch (and alternatives if risky): **low, only CSS
> changes**
> Frankly, I never quite believed this, and here is proof that with CSS you
> can bring the whole system down ;-)

The system isn't down, the window is only not movable and you can still work with your messages. When you look at the m-c patch, then you see where is a lot of JS and C++ changes. Naturally every code can harm but CSS normally has not so deep influence to make a system unusable (but you could make it invisible by setting everything transparent ;) ). And yes, in Mozilla land CSS can have more effect because it can also steer the XUL elements.

Comment 5

2 years ago
Comment on attachment 8716521 [details] [diff] [review]
dragFix.patch

Review of attachment 8716521 [details] [diff] [review]:
-----------------------------------------------------------------

Lgtm, works well on OS X.
Attachment #8716521 - Flags: review?(aleth) → review+

Updated

2 years ago
Keywords: checkin-needed

Comment 6

2 years ago
https://hg.mozilla.org/comm-central/rev/0fe10e9c32454314c22058caedc4e259b8bc3971
Bug 1246275 - Remove window-drag bindings and use on #titlebar -moz-window-dragging: drag; r=aleth a=me CLOSED TREE

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 47.0

Updated

2 years ago
Blocks: 1219215
Keywords: regression
You need to log in before you can comment on or make changes to this bug.