WebVR produces flickering in fullscreen mode

RESOLVED DUPLICATE of bug 1247082

Status

()

Core
Layout: View Rendering
RESOLVED DUPLICATE of bug 1247082
2 years ago
2 years ago

People

(Reporter: iprotsyuk, Unassigned)

Tracking

({regression})

47 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox46 unaffected, firefox47 fixed)

Details

(Whiteboard: [webvr])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.103 Safari/537.36

Steps to reproduce:

1. Connect Occulus Rift to a PC
2. Run Nightly
3. Open any web-site with a WebVR demo, for example http://cabbi.bo/RainbowMembrane/
4. Double-click at the main canvas to enter VR mode


Actual results:

VR scene is rendered at the Rift display, but it's flickering.

My guess is that it can be caused by latest Nightly updates because the Rift doesn't show any flickering when other programs use it.


Expected results:

VR scene is rendered without visible flickering.

Updated

2 years ago
Component: Untriaged → Layout
Product: Firefox → Core
(Reporter)

Comment 1

2 years ago
Something went wrong after the upgrade to 47 version indeed. I've just installed the latest 46 branch build (46.0a1, 2016-01-25), and it produces no flickering when rendering.

Comment 2

2 years ago
Is it testable without having Occulus Rift? (I guess not)
(Reporter)

Comment 3

2 years ago
(In reply to Loic from comment #2)
> Is it testable without having Occulus Rift? (I guess not)

Yep, it isn't. Everything is ok on the screen. The problem appears only when I enable rendering on Oculus. I'm not sure if it's reproducible with other VR devices. For the record, I'm using Oculus Rift DK2 and Oculus runtime version 0.8.

Comment 4

2 years ago
Ok, so as you have the device to test and reproduce the issue, could you install the tool Mozregression to find a regression range in FF47.
See http://forums.mozillazine.org/ for details. You need to install python 2.7 to run this packgage.
After that, paste here the final pushlog provided in the console output.
Keywords: regressionwindow-wanted

Comment 5

2 years ago
Sorry, wrong copypasta, the link is http://mozilla.github.io/mozregression/

Updated

2 years ago
Flags: needinfo?(iprotsyuk)

Updated

2 years ago
Component: Layout → General
Whiteboard: [webvr]
(Reporter)

Comment 6

2 years ago
(In reply to Loic from comment #5)
> Sorry, wrong copypasta, the link is http://mozilla.github.io/mozregression/

This is what mozregression showed at the end:

Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1064843

Can send a whole log if needed.
Flags: needinfo?(iprotsyuk)
(Reporter)

Comment 7

2 years ago
Created attachment 8718910 [details]
mozregression_output.txt

mozregression output

Comment 8

2 years ago
Ty for the reg range.
Blocks: 1064843
status-firefox46: --- → unaffected
status-firefox47: --- → affected
tracking-firefox47: --- → ?
Component: General → Layout: View Rendering
Flags: needinfo?(quanxunzhen)
Keywords: regressionwindow-wanted → regression
A fix has been landed in bug 1247082 so mark this duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(quanxunzhen)
Resolution: --- → DUPLICATE
Duplicate of bug: 1247082

Comment 10

2 years ago
Flags removed because of duped.
tracking-firefox47: ? → ---
status-firefox47: affected → fixed
You need to log in before you can comment on or make changes to this bug.