If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Copy/paste from a plain text message loses white-space at beginnings of lines.

RESOLVED DUPLICATE of bug 1193153

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 1193153
2 years ago
2 years ago

People

(Reporter: Peter Langston, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/601.4.4 (KHTML, like Gecko) Version/9.0.3 Safari/601.4.4

Steps to reproduce:

I typed this into a plaintext email message:

Dear Correspondent,
     I am indenting this first line of my paragraph
because that's how I want my paragraph to be formatted.



Actual results:

I copied and pasted those three lines and what appeared was:

Dear Correspondent,
I am indenting this first line of my paragraph
because that's how I want my paragraph to be formatted.



Expected results:

The copy/paste should not delete the leading spaces on any lines.  The pasted lines should look just like the copied lines, e.g.:

Dear Correspondent,
     I am indenting this first line of my paragraph
because that's how I want my paragraph to be formatted.

This bug is not the same as any FIXED bug (e.g. bug 1193153) because it is not fixed.
I'm running Thunderbird 38.5.1 which I'm told is the release channel version.
(Reporter)

Comment 1

2 years ago
I understand this has been fixed in a version that has not yet appeared on the release channel.

<Emily Latella mode on> Never mind... <Emily Letella mode off>

-=P=-
(Reporter)

Comment 2

2 years ago
(In reply to Peter Langston from comment #1)
> I understand this has been fixed in a version that has not yet appeared on
> the release channel.
> 
> <Emily Latella mode on> Never mind... <Emily Letella mode off>
> 
> -=P=-

Yes!
I now have v45.0 and this bug is fixed.
Thank you!
-=P=-
status of a bug in bugzilla is to reflect the development code base, not necessarily what is in the currently public shipping version. So duping to bug 1193153 which is fixed in development.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1193153
Reporter and QA agree that this is a dupe of 1193153, so Summary shouldn't say the opposite.
Summary: Copy/paste from a plain text message loses white-space at beginnings of lines. Not Bug 1193153! → Copy/paste from a plain text message loses white-space at beginnings of lines.
You need to log in before you can comment on or make changes to this bug.