Closed Bug 1247143 Opened 5 years ago Closed 5 years ago

<a rel=alternate> doesn't show up in Menu -> Bookmarks -> Subscribe to this page ...

Categories

(Firefox Graveyard :: RSS Discovery and Preview, defect)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 362864

People

(Reporter: hello, Unassigned)

Details

(Keywords: dev-doc-complete)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160123151951

Steps to reproduce:

I went to https://kartikprabhu.com/ which has a <a rel="alternate feed" type="application/atom+xml" href="/atom" title="Atom feed for Homepage">Homepage</a> in its HTML.


Actual results:

I opened the Menu -> Bookmarks and the "Subscribe to this page ..." was grayed out so I wasn't able to subscribe to this feed.


Expected results:

It should have let me subscribe to this feed like if instead the website has used <link> instead of <a>, which is described as an alternative way to do it here: https://developer.mozilla.org/en-US/docs/Web/RSS/Getting_Started/Syndicating#Adding_the_.3Ca.3E
Severity: normal → trivial
Component: Untriaged → RSS Discovery and Preview
Severity: trivial → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
I did not find any version of Firefox support the form.
Component: RSS Discovery and Preview → General
Product: Firefox → Developer Documentation
Version: 44 Branch → unspecified
in my opinion the documentation is right and it is a bug in Firefox, because there are obviously websites out there using it in that way.
However, any browser explicitly support it?
I think the docs (browser-independent) is right, but Firefox doesn't act on it. Moving it back to Firefox and it product management will decide to implement this feature or WONTFIX it.
Component: General → RSS Discovery and Preview
Product: Developer Documentation → Firefox
I've added a note to the doc indicating this doesn't work in Firefox. See https://developer.mozilla.org/en-US/docs/Web/RSS/Getting_Started/Syndicating#Adding_the_.3Ca.3E for that.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 362864
I'm not sure there is anything, other than maybe someone's extension for some browser or someone's autodiscovery script, which does support <a rel> autodiscovery. Safari doesn't, Chrome doesn't seem to have built-in support for autodiscovery anymore, Edge doesn't seem to either.
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.