TEST-UNEXPECTED-FAIL | /builds/slave/test/build/tests/mozmill/testBasicFunctionality.js | testBasicFunctionality.js::testSmokeTest

RESOLVED FIXED in 4.8

Status

defect
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: aleth, Assigned: aleth)

Tracking

({intermittent-failure})

Lightning 4.8
Dependency tree / graph

Details

Attachments

(1 attachment)

INFO -  SUMMARY-UNEXPECTED-FAIL | testBasicFunctionality.js | testBasicFunctionality.js::testSmokeTest
 05:18:14     INFO -    EXCEPTION: missing ] after element list
 05:18:14     INFO -      at: gdata-calendar-creation.js line 126
Assignee: nobody → aleth
Status: NEW → ASSIGNED
Blocks: 1237602
Out of curiosity: Is this a recent regression? Linux x64 opt, OS X 10.10 opt from 11-Feb and Windows from 10-Feb ago don't show this Mozmill failure. Or do they not execute the Calendar tests?
(In reply to Stefan Sitter from comment #2)
> Out of curiosity: Is this a recent regression? Linux x64 opt, OS X 10.10 opt
> from 11-Feb and Windows from 10-Feb ago don't show this Mozmill failure. Or
> do they not execute the Calendar tests?

It appears to be Linux32 only (and that was busted until today). Why it's Linux32-only is an interesting question -  I don't know this code and haven't looked into it.
Component: Testing Infrastructure → Provider: GData
Product: Thunderbird → Calendar
Version: Trunk → Lightning 4.9
Comment on attachment 8718393 [details] [diff] [review]
Replace array comprehension in gdata-calendar-creation.js

Review of attachment 8718393 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with a traditional function:

::: calendar/providers/gdata/content/gdata-calendar-creation.js
@@ +122,5 @@
>          let sessionContainer = document.getElementById("gdata-session-group");
>          let newSessionItem = document.getElementById("session-new");
>          let calendars = cal.getCalendarManager().getCalendars({});
> +        let sessions =
> +          new Set(calendars.map(calendar => sessionMgr.getSessionByCalendar(calendar, true)));

Unfortunately can't do arrow functions in gecko 8. Set is shimmed, but arrow functions are syntax.
Attachment #8718393 - Flags: review?(philipp) → review+
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 4.9
Comment on attachment 8718393 [details] [diff] [review]
Replace array comprehension in gdata-calendar-creation.js

Needs uplift to match the dependent bug.
Attachment #8718393 - Flags: approval-calendar-aurora?(philipp)
Attachment #8718393 - Flags: approval-calendar-aurora?(philipp) → approval-calendar-aurora+
https://hg.mozilla.org/releases/comm-aurora/rev/d79fb6f7dc0f5e5d3b2aa6ec57dc006bbcbd8e7d
Bug 1247653 - Replace array comprehension in gdata-calendar-creation.js. r=Fallen a=Fallen
Target Milestone: 4.9 → 4.8
Version: Lightning 4.9 → Lightning 4.8
Duplicate of this bug: 1282387
You need to log in before you can comment on or make changes to this bug.