With UnMHT add-on, after switching to another tab, the another tab still shows url of a previous tab.

RESOLVED FIXED

Status

()

P4
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: marcino245, Unassigned)

Tracking

47 Branch
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: triaged)

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

3 years ago
Created attachment 8719137 [details]
Firefox Nightly 47_0a1 an incorrect (old) url (+ some [unrealted?] glitches after scrolling).png

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160211075855

Steps to reproduce:

First way:
1. Start browser with a start page.
1. Open a new tab.
2. Switch to a previous tab (to the start page).

Second way (if you have some tabs opened already):
1. Being on currently active tab, first make sure it is showing a proper (it's own) url.
2. Then switch to anothetr tab.


Actual results:

After switching to another tab, the another tab still shows url of a previous tab. 


Expected results:

An active tab should show it's own proper url instead of showing an url of a previous (old) tab.

The incorrect url frequency - appears almost always (often), but not always, and sometimes it gets fixed after switching X times between the affected tab to another / adjacent tab.

Another way to fix an incorrect url is to reload an affected tab.

The bug began with version Firefox Nightly 47.0a1 which I installed about 2016-02-11 00:48:32 PST and still occurs after several nightly updates.  As I had no earlier versions installed before, I dont know if the bug occured in earlier versions than 47.0a1.

I don't consider this as a drawing bug (a visual gltich) because I can select and copy the old url as a text. (But as I'm not an expert I'm not sure at 100% if this is unrelated as I also had some visual glitches sometimes when scrolling websites [I'm gonna to fill that visual glitch later as another bug]).
(Reporter)

Comment 1

3 years ago
Possible related to https://bugzilla.mozilla.org/show_bug.cgi?id=257043 ?
OS: Unspecified → Windows XP
Hardware: Unspecified → x86
(Reporter)

Comment 2

3 years ago
(or If the bug will be considered as a visual glitch it may be possible related to https://bugzilla.mozilla.org/show_bug.cgi?id=1067470)
(Reporter)

Comment 3

3 years ago
Created attachment 8719150 [details]
(2) Firefox Nightly 47_0a1 an incorrect (old) url (without a scrolling visual glitch).png
(Reporter)

Comment 4

3 years ago
Before I switched to Firefox Nightly 47.0a1, I was on a normal version of Firefox (Firefox 44.01 and previous) and I had no tab/url problems. So the problem seems to be Nightly exclusive.

Updated

3 years ago
Component: Untriaged → Location Bar

Comment 5

3 years ago
Are you able to reproduce the issue with a clean profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(marcino245)
(Reporter)

Comment 6

3 years ago
I made a fresh profile, but it did not help, so I switched back to my profile.

And then I disabled

> Options >> General >> Startup >> Enable multi-process Nightly

and restarted Nightly, and all the three problems:

https://bugzilla.mozilla.org/show_bug.cgi?id=1248120
https://bugzilla.mozilla.org/show_bug.cgi?id=1248125
https://bugzilla.mozilla.org/show_bug.cgi?id=851133

dissapeared as if by magic.

So the cause of all the problems is the multi-process.

However I'm not sure if the problems (bugs) may be considered as resolved (closed), as disabling the multi-process is just a workaaround and the real solution is to fix the multi-process.
Flags: needinfo?(marcino245)
(Reporter)

Updated

3 years ago
tracking-e10s: --- → ?

Updated

3 years ago
Flags: needinfo?(twalker)
marcino,

Please attach a full copy of your about:support, including the list of add-ons you have installed when encountering this bug.  Preferably, run with a completely fresh profile with no add-ons installed in that profile.

Thanks you.
Flags: needinfo?(twalker)

Updated

3 years ago
Flags: needinfo?(marcino245)
(Reporter)

Comment 8

3 years ago
TracyWalker,

I think that you did not notice that I already mentioned that
> I made a fresh profile, but that did not help
and a fresh profile has no add-ons installed. 

But if you have noticed that and despite this you still for some other reasons need a full copy of about:support of my fresh profile, let me know.
Flags: needinfo?(marcino245)
yes, please provide full about:support

also, screen captures of the issue happening that do not show you're running add-ons.
Flags: needinfo?(marcino245)
(Reporter)

Comment 10

3 years ago
> Application Basics
> ------------------
> 
> Name: Firefox
> Version: 47.0a1
> Build ID: 20160217062621
> Update Channel: nightly
> User Agent: Mozilla/5.0 (Windows NT 5.1; rv:47.0) Gecko/20100101 Firefox/47.0
> OS: Windows_NT 5.1 x86
> Multiprocess Windows: 1/1 (Enabled by user)
> Safe Mode: false
> 
> Crash Reports for the Last 3 Days
> ---------------------------------
> 
> Report ID: bp-da5b16cc-8199-48e1-95e8-7a1dd2160215
> Submitted: 2 days ago
> 
> All Crash Reports
> 
> Extensions
> ----------
> 
> Name: Firefox Hello Beta
> Version: 1.1.2
> Enabled: true
> ID: loop@mozilla.org
> 
> Name: Pocket
> Version: 47.0a1
> Enabled: true
> ID: firefox@getpocket.com
> 
> Name: Microsoft .NET Framework Assistant
> Version: 1.0
> Enabled: false
> ID: {20a82645-c095-46ed-80e3-08825760534b}
> 
> Graphics
> --------
> 
> Adapter Description: Intel(R) HD Graphics
> Adapter Drivers: igxprd32
> Adapter RAM: Unknown
> Asynchronous Pan/Zoom: wheel input enabled; touch input enabled
> Device ID: 0x0102
> Direct2D Enabled: Blocked for your graphics driver version.
> DirectWrite Enabled: false (0.0.0.0)
> Driver Date: 2-4-2013
> Driver Version: 6.14.10.5437
> GPU #2 Active: false
> GPU Accelerated Windows: 0/1 Basic (OMTC)
> Subsys ID: 77881462
> Supports Hardware H264 Decoding: No; Failed to create H264 decoder
> Vendor ID: 0x8086
> WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9 vs_3_0 ps_3_0)
> windowLayerManagerRemote: true
> AzureCanvasBackend: skia
> AzureContentBackend: cairo
> AzureFallbackCanvasBackend: cairo
> AzureSkiaAccelerated: 0
> 
> Important Modified Preferences
> ------------------------------
> 
> browser.cache.disk.capacity: 358400
> browser.cache.disk.filesystem_reported: 1
> browser.cache.disk.smart_size.first_run: false
> browser.cache.disk.smart_size.use_old_max: false
> browser.cache.frecency_experiment: 4
> browser.download.importedFromSqlite: true
> browser.places.smartBookmarksVersion: 7
> browser.sessionstore.upgradeBackup.latestBuildID: 20160217062621
> browser.startup.homepage_override.buildID: 20160217062621
> browser.startup.homepage_override.mstone: 47.0a1
> browser.tabs.remote.autostart: true
> browser.tabs.remote.autostart.2: false
> dom.apps.reset-permissions: true
> dom.mozApps.used: true
> extensions.lastAppVersion: 47.0a1
> gfx.blacklist.direct2d: 3
> media.gmp-gmpopenh264.abi: x86-msvc-x86
> media.gmp-gmpopenh264.lastUpdate: 1455620583
> media.gmp-gmpopenh264.version: 1.5.3
> media.gmp-manager.buildID: 20160217062621
> media.gmp-manager.lastCheck: 1455740785
> media.hardware-video-decoding.failed: true
> network.cookie.prefsMigrated: true
> network.predictor.cleaned-up: true
> places.history.expiration.transient_current_max_pages: 91303
> plugin.disable_full_page_plugin_for_types: application/pdf
> plugin.importedState: true
> services.sync.declinedEngines:
> 
> Important Locked Preferences
> ----------------------------
> 
> JavaScript
> ----------
> 
> Incremental GC: true
> 
> Accessibility
> -------------
> 
> Activated: false
> Prevent Accessibility: 0
> 
> Library Versions
> ----------------
> 
> NSPR
> Expected minimum version: 4.12 Beta
> Version in use: 4.12 Beta
> 
> NSS
> Expected minimum version: 3.23 Basic ECC Beta
> Version in use: 3.23 Basic ECC Beta
> 
> NSSSMIME
> Expected minimum version: 3.23 Basic ECC Beta
> Version in use: 3.23 Basic ECC Beta
> 
> NSSSSL
> Expected minimum version: 3.23 Basic ECC Beta
> Version in use: 3.23 Basic ECC Beta
> 
> NSSUTIL
> Expected minimum version: 3.23 Beta
> Version in use: 3.23 Beta
> 
> Experimental Features
> ---------------------
> 

As for the screenshoots I will update them later (soon, I don't if know if today or tomorrow)
Flags: needinfo?(marcino245)
(Reporter)

Comment 11

3 years ago
I retested on a fresh profile again and the bug is gone, So I retested on my private profile (with many add-ons and own settings, as seen on the screenshoots) again and the bug still is appearing. This suggested to me that the bug occurs when some add-on(s) is enabled, so I did a deeper investigation by disabling the add-ons one after the other, then restarting the browser and testing again. I quickly found the add-on which "causes" the bug. It is UnMHT 8.1.0. Then I disabled all the other add-ons except for UnMHT 8.1.0, and restarted the browser and the bug still was here. But to be sure at 100% that the reason is UnMHT 8.1.0 I installed UnMHT 8.1.0 onto the fresh profile, and the bug doesn't appear. So it seemed that the reason is UnMHT 8.1.0 not compatible with something in my profile or vice versa. So I was continuing the investigation, to check if it was one of last Nightlies fixing the bug, so I installed the older Nightly again (Build ID: 20160211075855 - the orginal one from the bug description), run the fresh profile, then installed UnMHT 8.1.0 onto it, restarted the browser, and the bug appeared again in the fresh profile (as expected), then I updated to the latest Nightly, restarted the browser and...the bug still is here again in the latest Nightly. So I uninstalled UnMHT 8.1.0, restarted the browser, installed UnMHT 8.1.0 again, restarted the browser and the bug still is here. So I created an another fresh profile, installed UnMHT 8.1.0, restarted the browser, but the bug still is here. I noticed several times that after installing UnMHT 8.1.0, and closing the browser and starting again, when in "choose user profile" window, I'm trying to run a profile and I get an error message

> Nightly cannot use the profile because it is in use.
>
> To continue close the running instance of Nightly or choose a different profile.

And after about 30 seconds, finally the error message dissapear and I can run the profile again.

It seems UnMHT 8.1.0 causing the problems with closing the profile as well as causing the bug. But I wonder why the bug was gone in the latest Nightly (on a fresh profile) an hour ago, and appeared again after reinstalling the latest Nightly again?

As you may see, someone should install UnMHT 8.1.0...and confirm if it is causing the bug to other people or to me only. If it cause the bug for other people too, this mean UnMHT 8.1.0 is old, not developed and therefore incompatible as the latest release is from 04 December 2016 and this is 2.5 months ago. So it should be blocked by Firefox as incombatible.

After someone investigate this and confirm UnMHT 8.1.0 as causing (or not) the bug for the others too, you may close the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Updated

3 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 12

3 years ago
If you installed UnMHT 8.1.0 and want to trigger the bug you have to open several different tabs (websites), and then keep switching randomly between the tabs, paying attention to the url adress.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → INVALID
(Reporter)

Updated

3 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 13

3 years ago
Not every single switch between the tabs do trigger the bug, so keep switching some more - just keep clicking randomly on tabs (switching) X times like 10, 20 or 30.
(Reporter)

Comment 14

3 years ago
Until one of the active tab lose it's own url, and show an old url (of the previous tab).
(Reporter)

Comment 15

3 years ago
Created attachment 8720731 [details]
Profile In Use Error.png
(Reporter)

Comment 16

3 years ago
Created attachment 8720752 [details]
[on a fresh profile + UnMHT 8.1.0] the add-on causing previous active tab's url stay.png
Attachment #8719137 - Attachment is obsolete: true
Attachment #8719150 - Attachment is obsolete: true
(Reporter)

Comment 17

3 years ago
Created attachment 8720753 [details]
[on a fresh profile + UnMHT 8.1.0] the add-on causing previous active tab's url stay.png
Attachment #8720752 - Attachment is obsolete: true
marcino,  thank you for digging into your add-ons and determining which one is causing the issue.  There is already a basic bug on file for UnMHT being broken.  I have marked this bug blocking bug 1202149.
Blocks: 905436, 1202149
Status: UNCONFIRMED → NEW
tracking-e10s: ? → +
Ever confirmed: true
Summary: After switching to another tab, the another tab still shows url of a previous tab. → With UnMHT add-on, after switching to another tab, the another tab still shows url of a previous tab.

Updated

2 years ago
Priority: -- → P4
Whiteboard: triaged
Released Ver.8.2.0, that is disabled on e10s.
Status: NEW → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.