Closed Bug 1248174 Opened 4 years ago Closed 4 years ago

<input> & <select> elements are too long in "Google Apps for Work" google calendar with long calendar-name

Categories

(Core :: Layout, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox44 --- unaffected
firefox45 --- unaffected
firefox46 --- fixed
firefox47 --- fixed

People

(Reporter: dholbert, Assigned: dbaron)

References

Details

Attachments

(1 file)

Attached image screenshot of bug
STR:
 0. Log in to a Google Apps For Work google calendar account. (This does not reproduce with my personal Google Calendar account.)

  If you're a Mozilla employee, sign in at https://sso.mozilla.com/gcalendar

 2. Click a blank time-slot on the calendar to bring up the "Add Event" box.

ACTUAL RESULTS:
<input> & <select> elements are too long & get clipped. See screenshot.

EXPECTED RESULTS:
These elements should fit & not get clipped.


Regression range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=03297f8c28a08d2b39a252c7b368524d9e69da69&tochange=1dbe350b57b17ec1ce2887441b79c6f51b429378

Looks like a regression from bug 823483.
There's a good chance this is a dupe of bug 1247897, which has the same regression range but is at a different site.

Filing separately for now, since this is a different high-profile site & might be worth tracking independently -- but we can dupe later as-appropriate/desired.
I verified that this reproduces in up-to-date Aurora, too (which makes sense because bug 823483 was backported there).

[Canceling my tracking request, since there are already tracking requests on bug 1247897]
I can't actually repro the bug; I'm guessing you have a calendar in that select with a particularly long name.

However, I strongly suspect it will be fixed by the patches I will attach to bug 1247929.
Depends on: 1247929
(In reply to David Baron [:dbaron] ⌚️UTC-8 from comment #3)
> I can't actually repro the bug; I'm guessing you have a calendar in that
> select with a particularly long name

Thanks -- that is exactly it. The calendar is named "Platform Engineering & CTO Holiday/PTO Calendar". If I use devtools to shorten that calendar's name in the dropdown list, this bug goes away.
Summary: <input> & <select> elements are too long in "Google Apps for Work" google calendar → <input> & <select> elements are too long in "Google Apps for Work" google calendar with long calendar-name
I believe this is fixed by bug 1247929, though I'd appreciate if dholbert could confirm.
Assignee: nobody → dbaron
Flags: needinfo?(dholbert)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Yes, this is fixed in latest Nightly 47.0a1 (2016-02-25).  Thanks!
Status: RESOLVED → VERIFIED
Flags: needinfo?(dholbert)
Fixed for 46 by landing of bug 1247929 on mozilla-aurora (bug 1247929 comment 25).
You need to log in before you can comment on or make changes to this bug.