SpeechSynthesis ceases to work

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: datapartners, Unassigned)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160210153822

Steps to reproduce:

Firefox version 44.0.2 bug is SpeechSynthesis ceases to work if interrupted with loading of another page or upon page refresh with SpeechSynthesis.cancel onunload and beforeunload.   No error is thrown on any subsequent SpeechSynthesisUtterance.speak attempt, with the SpeechSynthesis going into what appears to be an unrecoverable state.  


Actual results:

SpeechSynthesis ceases to work. Only way to get SpeechSynthesis working again is to close the browser instance and open another.  


Expected results:

The use case is common for a number of reasons, so the SpeechSynthesis should be able to accommodate this especially if the SpeechSynthesis is cancelled.

Updated

3 years ago
Component: Untriaged → Web Speech
Product: Firefox → Core
I think that this is already fixed by bug 1230533.  Could you test the latest Nightly?
Flags: needinfo?(datapartners)
(Reporter)

Comment 2

3 years ago
Thanks for the reply Makoto

Tested against the nightly build 47.0a1 (2016-02-17) as suggested with the same outcome. The test cases I have looked at involve only the SpeechSynthesis.speaking and SpeechSynthesis.pause states, it did’nt included SpeechSynthesis.pending. It appears that once the SpeechSynthesis is interrupted either by page refresh or by pausing, its lights out for the browser if you want to get it going again.
Flags: needinfo?(datapartners)
Blocks: 1268633
Michael,

I tried to reproduce this on windows with no success. Can you provide a file that reproduces this for you on Nightly?
Flags: needinfo?(datapartners)
(Reporter)

Comment 4

2 years ago
Thanks for the reply Eitan,

Tested again on FF 49.0a1 (2016-05-27) e-US win64.

Test One
Step	Action	                                                       Result
1	Start the webspeech object reading text	                       Object starts reading text
2	Reload page while the webspeech object is still processing.    Page reloads
3	Restart the webspeech object reading text	               Object restarts reading text

Test Two
Step	Action	                                                       Result
1	Start webspeech object reading text	                       Object starts reading text
2	Call the cancel() method before reloading page.	               Page reloads
3	Restart webspeech object reading text	                       Object restarts reading text

Test Three
Step	Action	                                                       Result
1	Start webspeech object reading text	                       Object starts reading text
2	Call the pause() method before reloading page.	               Page reloads
3	Restart webspeech object reading text	                       Object restarts reading text

Current version 46.0.1 failes tests two and three by calling either .cancel() or .pause() before reloading. The nightly results look all good to me, so you can close the case.

Cheers Michael
Thanks Michael!

Case three would have been broken before bug 1230533 landed, so I assume that fixed it. Case two is a bit more puzzling to me, but if you can't reproduce it with current nightlies I am going to close this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(datapartners)
You need to log in before you can comment on or make changes to this bug.