Debugger shows stale HTML files if toolbox disabled caching

VERIFIED FIXED in Firefox 60

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
Last year

People

(Reporter: jryans, Assigned: jryans)

Tracking

(Blocks 1 bug)

Trunk
Firefox 60
Dependency tree / graph

Firefox Tracking Flags

(firefox60 verified)

Details

Attachments

(1 attachment, 2 obsolete attachments)

For HTML files with inline scripts, we currently load them from cache.  However, the toolbox default to disabling caching for the page.

When these concepts combine, we can end up loading stale content for HTML sources.
Posted patch debugger-source-caching (obsolete) — Splinter Review
I assume this should have a test...  Are there existing tests that toggle file caching like this?
Attachment #8719623 - Flags: feedback?(nfitzgerald)
Invalid patch file?
Flags: needinfo?(jryans)
Attachment #8719623 - Flags: feedback?(nfitzgerald)
Posted patch debugger-source-caching (obsolete) — Splinter Review
Let's try that again...
Attachment #8719623 - Attachment is obsolete: true
Flags: needinfo?(jryans)
Attachment #8720097 - Flags: feedback?(nfitzgerald)
Attachment #8720097 - Flags: feedback?(nfitzgerald) → feedback+
Priority: -- → P2
Bug 1060732 might be related, we should re-test this after it lands.
See Also: → 1060732
Assignee: jryans → nobody
Status: ASSIGNED → NEW
Assignee: nobody → jryans
Status: NEW → ASSIGNED
Attachment #8720097 - Attachment is obsolete: true
Comment on attachment 8954998 [details]
Bug 1248498 - Check document cache status when loading HTML sources.

https://reviewboard.mozilla.org/r/224180/#review230224

Looks great!
Attachment #8954998 - Flags: review?(jlaster) → review+
Pushed by jryans@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f0a37e176064
Check document cache status when loading HTML sources. r=jlast
https://hg.mozilla.org/mozilla-central/rev/f0a37e176064
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Erik, a fix for this is now included in Nightly 60.  Could you try it out[1] to check whether it resolves the issue you were seeing?

[1]: https://nightly.mozilla.org
Flags: needinfo?(erik.krause)
Seems to be fixed in nightly 60.0a1 (2018-03-06) (64-Bit) but not in developer edition 60.0b1 (64-Bit).
Flags: needinfo?(erik.krause)
Thanks!  I believe it should appear in Dev Ed in a few days.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1363534
Duplicate of this bug: 1445494
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.