Closed Bug 1248749 Opened 4 years ago Closed 4 years ago

<select> does not shrink to percent% width

Categories

(Core :: Layout: Form Controls, defect)

46 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox45 --- unaffected
firefox46 + fixed
firefox47 + fixed

People

(Reporter: alice0775, Assigned: dbaron)

References

Details

(Keywords: regression, Whiteboard: [parity-IE] [parity-Chrome][parity-Edge])

Attachments

(1 file)

Attached file testcase
[Tracking Requested - why for this release]: layout broken

Steps to to reproduce:
1 Open testcase

Actual Results:
Select boxes are too wide

Expected Results:
Two select boxes should fit to browser width
(i.e, in this case, the width of <select> should be 1/2 width of window)

This happens since Bug 823483
Tracking, recent regression.
I'll plan to fix miscategorization of form controls in bug 1247929.
Depends on: 1247929
I'd say it's a dupe of bug 1247897.
This is fixed by the patches I will attach to bug 1247929.
Fixed by bug 1247929.
Assignee: nobody → dbaron
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Fixed for 46 by landing of bug 1247929 on mozilla-aurora (bug 1247929 comment 25).
You need to log in before you can comment on or make changes to this bug.