Provide options for users to view URL on TV Web Apps listings

VERIFIED FIXED

Status

P1
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: jcheng, Assigned: jyeh)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 verified, b2g-master verified)

Details

(Whiteboard: [ft:conndevices])

Attachments

(3 attachments)

base on latest discussion with various groups, we should add an option for users to "view URL" on TV Web Apps listings

Comment 1

3 years ago
+1 for Tori's Option # 3 - "Place URL inside option menu"

I think this approach would be best, given the URLs we have today. For illustration, here is an example of two of our current content URLs:

Cliggo - http://music-dev.cliggo.com/includes/app_specials/tv/?device=mobile&tv=panasonic
Bust A Move - http://d3divlwnjap65x.cloudfront.net/
Tori,
blocking-b2g: --- → 2.5+
Whiteboard: [ft:conndevices]
Hi Tori,
Could you update the UX spec to reflect this so Joseph can work on that?
Thanks
Flags: needinfo?(tchen)

Updated

3 years ago
Blocks: 1204762

Comment 4

3 years ago
Please check the updated spec here (v2.3 p26~27)
https://drive.google.com/open?id=0B4dMhI4hp32OWllCWHBkQXlnbFE
Flags: needinfo?(tchen) → needinfo?(jocheng)

Updated

3 years ago
Blocks: 1250032

Comment 5

3 years ago
Comments from previous discussion in email thread for record

proposals
https://docs.google.com/a/mozilla.com/presentation/d/18GKw5fc6Z3tvqdSNerGPnYHe-ZaLNqBK6zNT5h0sftk/edit?usp=sharing

Joe: #3 looks good, like what we discussed in the morning

Michael: +1 for Option 3 - "Place URL in option menu"

Elvin:  For the interim, the URL should be 'visible' to users, but we should process that URL as we would in any other context. Longer term something like Option 1 or 2 would be preferred as it makes most clear who is responsible for the content and sets users expectations right off the bat.

Updated

3 years ago
No longer blocks: 1250032

Comment 6

3 years ago
Joseph, please checkout this spec and see if there is any missing piece. Question: for hosted app, do we know their launch URL in manifest from server side?
Assignee: nobody → jyeh
Flags: needinfo?(jyeh)

Updated

3 years ago
Flags: needinfo?(jocheng)

Updated

3 years ago
Blocks: 1250057
(Assignee)

Comment 7

3 years ago
Yes, api will give us the url of the hosted app.

However, in the spec p26, I'm not sure if we can change the text of ok button in a native confirm dialog. Or should this be handled by the system app?
Flags: needinfo?(jyeh) → needinfo?(ehung)
(Assignee)

Comment 8

3 years ago
After discussion with Luke and Ricky, it seems to be more appropriate to handled by the system app.
Flags: needinfo?(ehung)
Ricky,
Please help this, this is priority 1. Thanks
Flags: needinfo?(rchien)
Priority: -- → P1
After offline discussion, I will be a mentor for this issue helping mentee work on smart-system part.
Flags: needinfo?(rchien)
Hi Evelyn,
PLease help assign developer on this bug. Thanks
Flags: needinfo?(ehung)

Updated

3 years ago
Blocks: 1214243

Comment 12

3 years ago
Let's take option 3.
@tori, please provide your UX spec here, so Joseph can start working on it. Thanks!
Flags: needinfo?(ehung) → needinfo?(tchen)
Here is the latest ux spec (V2.5, p26.27), thanks!
https://drive.google.com/open?id=0B4dMhI4hp32OWllCWHBkQXlnbFE
Flags: needinfo?(tchen)
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 14

3 years ago
Created attachment 8725618 [details] [review]
jostw:josyeh/Marketplace/master/Bug1248853 > mozilla-b2g:master
Created attachment 8726032 [details] [review]
[gaia] jostw:josyeh/Marketplace/master/Bug1248853 > mozilla-b2g:master
(Assignee)

Comment 16

3 years ago
Comment on attachment 8726032 [details] [review]
[gaia] jostw:josyeh/Marketplace/master/Bug1248853 > mozilla-b2g:master

Hi Luke, this patch will add a context menu to show the link of the website. Please take a look at it, thanks!
Attachment #8726032 - Flags: review?(lchang)

Updated

3 years ago
Blocks: 1253145
Comment on attachment 8726032 [details] [review]
[gaia] jostw:josyeh/Marketplace/master/Bug1248853 > mozilla-b2g:master

Nice work!
Attachment #8726032 - Flags: review?(lchang) → review+
(Assignee)

Comment 18

3 years ago
Landed in gaia master.

https://github.com/mozilla-b2g/gaia/commit/f41e046a5c6032d9ce281fdb96256be7fc9b0c0f
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 19

3 years ago
Comment on attachment 8726032 [details] [review]
[gaia] jostw:josyeh/Marketplace/master/Bug1248853 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):1248853
[User impact] if declined: cannot see url of the website
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: Yes
Attachment #8726032 - Flags: approval-gaia-v2.5?(jocheng)
Comment on attachment 8726032 [details] [review]
[gaia] jostw:josyeh/Marketplace/master/Bug1248853 > mozilla-b2g:master

Approve for TV 2.5
Attachment #8726032 - Flags: approval-gaia-v2.5?(jocheng) → approval-gaia-v2.5+
Created attachment 8726650 [details] [review]
[gaia] jostw:v2.5 > mozilla-b2g:v2.5
(Assignee)

Comment 23

3 years ago
Uplift to gaia v2.5

https://github.com/mozilla-b2g/gaia/commit/07fc590a0a13f35420330d3d51c903cac7ba1208
status-b2g-v2.5: --- → fixed
status-b2g-master: --- → fixed

Updated

3 years ago
status-b2g-v2.5: fixed → verified
status-b2g-master: fixed → verified
You need to log in before you can comment on or make changes to this bug.