[DOGFOOD] Get msg: New msgs filtered into a folder do not appear while viewing that folder

VERIFIED FIXED in M14

Status

MailNews Core
Backend
P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: lchiang, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

19 years ago
Get msg: New msgs filtered into a folder do not appear while viewing that folder

1999082412 - m9 release build
Win32, IMAP, filter set up with an action to move certain messages to another
folder

1)  Start Messenger
2)  Select the Inbox
3)  Select the folder where you have messages filtered to and select a message
4)  From another machine, send yourself a few messages where the filter criteria
will be met
5)  From 5.0, click Get Msgs
6)  You will see that messages get retrieved (via the status bar text)

Actual results:  the filtered messages do not appear in the folder. You have to
select another folder and come back to this folder to see the new messages

Expected results:  following the get msgs command, new filtered messages should
show up in the folder that I'm currently viewing
(Assignee)

Comment 1

19 years ago
post b1 - we would need to do a lite select on the destination folder in order
to get it to update.
Status: NEW → ASSIGNED
Target Milestone: M13

Updated

19 years ago
Target Milestone: M13 → M14

Comment 2

19 years ago
M13 is pre-B1, so moving to M14

Updated

19 years ago
QA Contact: lchiang → laurel

Comment 3

19 years ago
fyi,
In the win32 1999-09-21-13-m11 and linux 1999-09-21-08 builds, I have to exit
seamonkey and relaunch it before I can see my filtered message.  The original
work around does not appear to be working.
(Assignee)

Comment 4

19 years ago
*** Bug 16985 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

19 years ago
Summary: Get msg: New msgs filtered into a folder do not appear while viewing that folder → [DOGFOOD] Get msg: New msgs filtered into a folder do not appear while viewing that folder
(Reporter)

Comment 5

19 years ago
I am going to mark this [DOGFOOD] because I really need this to be able to keep
5.0 up and running for a long time without having to always restart the
application.  I need to be able to read my bug notifications that get filtered
into a separate folder.

Updated

19 years ago
Whiteboard: [PDT+]
(Assignee)

Comment 6

19 years ago
You don't need to restart the application - you can just click another folder
and click back to the folder that had messages filtered into it.
(Reporter)

Comment 7

19 years ago
I tried to click back on the folder that has messages filtered into it. The
messages still don't show up.
(Reporter)

Comment 8

19 years ago
My mistake.  Switching folders will cause my filtered msgs to show up.
(Assignee)

Comment 9

19 years ago
Don't feel bad; I fixed that Thursday night.

Updated

19 years ago
Blocks: 17432
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

19 years ago
fixed by a bunch of changes too numerous to mention

Updated

19 years ago
Blocks: 17907
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

19 years ago
Yippee, this is now working.  Verified Win32 1999-11-09-11-m11 build.

Updated

18 years ago
No longer blocks: 17432

Updated

18 years ago
No longer blocks: 17907
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.