TEST-UNEXPECTED-FAIL | test_fallback_update.py TestFallbackUpdate.test_update & test_direct_update.py TestDirectUpdate.test_update | AssertionError: DownloadFailedPanel == DownloadFailedPanel (maxProgress is not equal to expected patch size)

RESOLVED WORKSFORME

Status

Testing
Firefox UI Tests
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: maja_zf, Unassigned)

Tracking

({intermittent-failure})

46 Branch
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
Traceback (most recent call last):
 09:10:36     INFO -   File "/Users/mozauto/jenkins/workspace/mozilla-aurora_update/build/venv/lib/python2.7/site-packages/marionette/marionette_test.py", line 344, in run
 09:10:36     INFO -     testMethod()
 09:10:36     INFO -   File "/Users/mozauto/jenkins/workspace/mozilla-aurora_update/build/venv/lib/python2.7/site-packages/firefox_ui_tests/update/fallback/test_fallback_update.py", line 20, in test_update
 09:10:36     INFO -     self.download_and_apply_available_update(force_fallback=True)
 09:10:36     INFO -   File "/Users/mozauto/jenkins/workspace/mozilla-aurora_update/build/venv/lib/python2.7/site-packages/firefox_puppeteer/testcases/update.py", line 301, in download_and_apply_available_update
 09:10:36     INFO -     self.download_update(about_window)
 09:10:36     INFO -   File "/Users/mozauto/jenkins/workspace/mozilla-aurora_update/build/venv/lib/python2.7/site-packages/firefox_puppeteer/testcases/update.py", line 283, in download_update
 09:10:36     INFO -     self.wait_for_download_finished(window, timeout)
 09:10:36     INFO -   File "/Users/mozauto/jenkins/workspace/mozilla-aurora_update/build/venv/lib/python2.7/site-packages/firefox_puppeteer/testcases/update.py", line 402, in wait_for_download_finished
 09:10:36     INFO -     window.deck.download_failed)
 09:10:36     INFO - TEST-INFO took 5226ms
 09:10:36     INFO - Update test results: 
 09:10:36     INFO - [{'build_post': None,
 09:10:36     INFO -   'build_pre': {'buildid': u'20160215004021',
 09:10:36     INFO -                 'channel': u'aurora',
 09:10:36     INFO -                 'disabled_addons': None,
 09:10:36     INFO -                 'locale': u'en-US',
 09:10:36     INFO -                 'mar_channels': set([u'firefox-mozilla-aurora']),
 09:10:36     INFO -                 'url_aus': u'https://aus5.mozilla.org/update/3/Firefox/46.0a2/20160215004021/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/aurora/Darwin%2013.4.0/default/default/update.xml?force=1',
 09:10:36     INFO -                 'user_agent': u'Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:46.0) Gecko/20100101 Firefox/46.0',
 09:10:36     INFO -                 'version': u'46.0a2'},
 09:10:36     INFO -   'fallback': True,
 09:10:36     INFO -   'patch': {'channel': u'aurora', 'download_duration': None},
 09:10:36     INFO -   'success': False}]
 09:10:36     INFO -  MARIONETTE LOG: INFO: TEST-END: /Users/mozauto/jenkins/workspace/mozilla-aurora_update/build/venv/lib/python2.7/site-packages/firefox_ui_tests/update/fallback/test_fallback_update.py:test_update
 09:10:36     INFO -  1455729036679	Marionette	WARN	A previous failed command left content listeners behind!
 09:10:36     INFO - Restoring channel defaults for: /Users/mozauto/jenkins/workspace/mozilla-aurora_update/build/application.copy/Contents/Resources/defaults/pref/channel-prefs.js
 09:10:36     INFO -
Some more lines from the updater log:

 09:10:20     INFO -  *** AUS:SVC Checker:getUpdateURL - update URL: https://aus5.mozilla.org/update/3/Firefox/46.0a2/20160215004021/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/aurora/Darwin%2013.4.0/default/default/update.xml?force=1
 09:10:20     INFO -  *** AUS:SVC Checker:checkForUpdates - sending request to: https://aus5.mozilla.org/update/3/Firefox/46.0a2/20160215004021/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/aurora/Darwin%2013.4.0/default/default/update.xml?force=1
 09:10:20     INFO -  *** AUS:SVC Checker:onLoad - request completed downloading document
 09:10:20     INFO -  *** AUS:SVC Checker:getUpdateURL - update URL: https://aus5.mozilla.org/update/3/Firefox/46.0a2/20160215004021/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/aurora/Darwin%2013.4.0/default/default/update.xml?force=1
 09:10:20     INFO -  *** AUS:SVC Checker:onLoad - number of updates available: 1
 09:10:20     INFO -  *** AUS:SVC getCanApplyUpdates - testing write access /Users/mozauto/Library/Caches/Mozilla/updates/Users/mozauto/jenkins/workspace/mozilla-aurora_update/build/application.copy/Contents/MacOS/update.test
 09:10:20     INFO -  *** AUS:SVC getCanApplyUpdates - testing write access /Users/mozauto/jenkins/workspace/mozilla-aurora_update/build/application.copy/Contents/MacOS/update.test
 09:10:20     INFO -  *** AUS:SVC getCanApplyUpdates - able to apply updates
 09:10:21     INFO -  *** AUS:SVC Creating Downloader
 09:10:21     INFO -  *** AUS:SVC UpdateService:_downloadUpdate
 09:10:21     INFO -  *** AUS:SVC readStringFromFile - file doesn't exist: /Users/mozauto/Library/Caches/Mozilla/updates/Users/mozauto/jenkins/workspace/mozilla-aurora_update/build/application.copy/Contents/MacOS/updates/0/update.status
 09:10:21     INFO -  *** AUS:SVC readStatusFile - status: null, path: /Users/mozauto/Library/Caches/Mozilla/updates/Users/mozauto/jenkins/workspace/mozilla-aurora_update/build/application.copy/Contents/MacOS/updates/0/update.status
 09:10:21     INFO -  *** AUS:SVC Downloader:downloadUpdate - downloading from http://download.cdn.mozilla.net/pub/firefox/nightly/2016/02/2016-02-17-00-40-09-mozilla-aurora/firefox-46.0a2.en-US.mac.complete.mar to /Users/mozauto/Library/Caches/Mozilla/updates/Users/mozauto/jenkins/workspace/mozilla-aurora_update/build/application.copy/Contents/MacOS/updates/0/update.mar
 09:10:21     INFO -  *** AUS:SVC Downloader:onStartRequest - original URI spec: http://download.cdn.mozilla.net/pub/firefox/nightly/2016/02/2016-02-17-00-40-09-mozilla-aurora/firefox-46.0a2.en-US.mac.complete.mar, final URI spec: http://download.cdn.mozilla.net/pub/firefox/nightly/2016/02/2016-02-17-00-40-09-mozilla-aurora/firefox-46.0a2.en-US.mac.complete.mar
 09:10:21     INFO -  *** AUS:SVC Downloader:onProgress - progress: 69504/111020060
 09:10:21     INFO -  *** AUS:SVC Downloader:onProgress - maxProgress: 111020060 is not equal to expected patch size: 111017442
 09:10:21     INFO -  *** AUS:SVC Downloader: cancel
 09:10:21     INFO -  *** AUS:SVC Downloader:onProgress - progress: 0/111020060
 09:10:21     INFO -  *** AUS:SVC Downloader:onProgress - maxProgress: 111020060 is not equal to expected patch size: 111017442
09:10:21 INFO - *** AUS:SVC Downloader: cancel

So the download fails because of an invalid maxProgress value. Sadly we do not have current values available given that newer builds have been published meanwhile. We would have to wait until this issue happens the next time.
Summary: TEST-UNEXPECTED-FAIL | test_fallback_update.py TestFallbackUpdate.test_update | AssertionError: DownloadFailedPanel == DownloadFailedPanel → TEST-UNEXPECTED-FAIL | test_fallback_update.py TestFallbackUpdate.test_update | AssertionError: DownloadFailedPanel == DownloadFailedPanel (maxProgress is not equal to expected patch size)
Summary: TEST-UNEXPECTED-FAIL | test_fallback_update.py TestFallbackUpdate.test_update | AssertionError: DownloadFailedPanel == DownloadFailedPanel (maxProgress is not equal to expected patch size) → TEST-UNEXPECTED-FAIL | test_fallback_update.py TestFallbackUpdate.test_update & test_direct_update.py TestDirectUpdate.test_update | AssertionError: DownloadFailedPanel == DownloadFailedPanel (maxProgress is not equal to expected patch size)
Duplicate of this bug: 1249466
Haven't seen this failure for about 5 months. Closing as WFM.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME

Comment 4

a year ago
8 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-release: 8

Platform breakdown:
* linux64: 4
* linux32: 4

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1249467&startday=2016-10-31&endday=2016-11-06&tree=all
You need to log in before you can comment on or make changes to this bug.