Closed Bug 1249500 Opened 6 years ago Closed 5 years ago

Graphical corruption when plugging in external monitor

Categories

(Core :: Graphics, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: dcamp, Assigned: bas.schouten)

References

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

I have a surface book.  When I plug in or remove an external monitor with a different DPI/UI scale, after resizing there's a bunch of graphics corruption.
This seemed to start happening after the 2/17 surface book update.
Dave, what's the external monitor model/setup?
Assignee: nobody → bas
Flags: needinfo?(dcamp)
Flags: needinfo?(bas)
Whiteboard: [gfx-noted]
External monitor connected over displayport.  I've seen this with a 1920x1200 monitor and a dell 4k.
Flags: needinfo?(dcamp)
This should be fixed on today's nightly.
Flags: needinfo?(bas)
Is it fixed?
Flags: needinfo?(bas)
It is for me.... but I've heard Dave and Andrew are experiencing things that I am not.
Flags: needinfo?(bas)
Yeah I'm still getting this sort of problem.
(In reply to Dave Camp (:dcamp) from comment #7)
> Yeah I'm still getting this sort of problem.

Alright, I think I managed to reproduce the problem that you might have, in order to verify I'm seeing the same thing, try the following:

Once you see the problem occur, switch to another window and maximize it, then switch back (all without minimizing the Firefox window) to Firefox and see if the artifacts have 'changed' to match whatever window you had behind it. For me the artifacted area seems to display the window behind it.
I will do that, but in the meantime:

The colors I see most are Black and an Orange color that matches my windows titlebar color.  So trying to reproduce you might need to have the "Show color on Start, taskbar, action center, and title bar" option chosen in personalize?
I just had it happen, and tried moving windows behind it.  No effect.  But when I tabbed away from the window the artifacts changed color from active titlebar color to background titlebar color.
I see this even on the laptop display regardless of whether an external display has been connected or not.
Yes - external display or changing the docking status seemed to be a slightly more likely way to cause the problem, but it isn't limited to that. We're looking at the latest Windows 10 preview, seems to have improved things somewhat.
True story. I opened the NVIDIA control panel and told it to make Firefox use the NVIDIA GPU (by default it forces it to the integrated GPU for some reason) and now the graphical issues have almost completely gone away. I do still see a single small blue box by tab favicons sometimes but I don't know if that is the same issue or something else.
blocking-b2g: 2.2r? → ---
Since installing the latest graphics driver update on my surface book this morning I haven't seen any UI corruption. This might be WFM now.
Dave, the "not seeing it anymore" is with the default setting, not just with forcing Nvidia GPU (as in comment 13)?
Flags: needinfo?(dtownsend)
(In reply to Milan Sreckovic [:milan] from comment #16)
> Dave, the "not seeing it anymore" is with the default setting, not just with
> forcing Nvidia GPU (as in comment 13)?

Yeah I turned that off a while ago since it means you can't disconnect the keyboard when Firefox is running.
Flags: needinfo?(dtownsend)
Other Dave :)  - is this gone for you as well?  Reopen if you still see it.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(dcamp)
Resolution: --- → WORKSFORME
This long nightmare appears to have come to an end.
Flags: needinfo?(dcamp)
You need to log in before you can comment on or make changes to this bug.