Remove NS_WARN_IF after AppendOriginNoSuffix in DOMStorageManager::CheckStorage

RESOLVED FIXED in Firefox 47

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mayhemer, Assigned: mayhemer)

Tracking

unspecified
mozilla47
Points:
---

Firefox Tracking Flags

(firefox47 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
It's a legal failure for about:blank that doesn't have a domain.
(Assignee)

Comment 1

3 years ago
Created attachment 8721994 [details] [diff] [review]
v1 (ultra simple one-liner)

- we call this method on more than one place and don't warn failures on them as well
- it's perfectly legal if the origin cannot be built for some edge cases like about:blank
Attachment #8721994 - Flags: review?(ehsan)

Updated

3 years ago
Attachment #8721994 - Flags: review?(ehsan) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1251026

Comment 4

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/1f797f47e312
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox47: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
You need to log in before you can comment on or make changes to this bug.