Closed Bug 1250404 Opened 6 years ago Closed 6 years ago

[TV][Marketplace] Visual polish for "Web App" icon

Categories

(Firefox OS Graveyard :: Gaia::TV, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

RESOLVED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.5 --- fixed
b2g-master --- fixed

People

(Reporter: tchen, Assigned: jyeh)

References

Details

(Whiteboard: [ft:conndevices])

Attachments

(5 files)

Current design on big screen looks little monotonous and not horizontally center aligned.
Attached image Web_Apps_modified.png
I tried to modify the background color of Web Apps icon and made the rocket a bit smaller. The gradient color is following the guideline (https://www.mozilla.org/en-US/styleguide/identity/firefoxos/color/). Please take a look at the visuals.
Attached image Web_Apps_current.png
Attached current Web Apps icon for reference.
Joe, can you take a look on this?
Flags: needinfo?(jcheng)
Whiteboard: [ft:conndevices]
blocking-b2g: --- → 2.5+
ni? David & Niran
looks fine to me
Flags: needinfo?(namir)
Flags: needinfo?(jcheng)
Flags: needinfo?(dbialer)
looks great to me.
Flags: needinfo?(dbialer)
Hi Joseph,
Please handle this bug. Thanks
Assignee: nobody → jyeh
Flags: needinfo?(jyeh)
The new Web Apps icon is updated. Link here: http://bit.ly/1THJwK8
Flags: needinfo?(jyeh)
Landed in marketplace-tv-front-end master.

https://github.com/mozilla-b2g/marketplace-tv-front-end/commit/fd7d73835506b911a56f138937a6e7a1b516c758


Still need another patch for gaia in order to update the app icon.
Will be done after the updated icon is serving on the production server.
looks OK
Flags: needinfo?(namir)
(In reply to Joseph Yeh from comment #9)
> Landed in marketplace-tv-front-end master.
> 
> https://github.com/mozilla-b2g/marketplace-tv-front-end/commit/
> fd7d73835506b911a56f138937a6e7a1b516c758
> 
> 
> Still need another patch for gaia in order to update the app icon.
> Will be done after the updated icon is serving on the production server.

Will you do it in a follow-up bug and close this one, or you prefer using this bug?
Flags: needinfo?(jyeh)
I prefer using this bug since this is already in Gaia::TV.
Flags: needinfo?(jyeh)
Joseph, any update here? Per you comment 9, is the icon on production server already?
Flags: needinfo?(jyeh)
I don't know why they miss this on last week's release :(

I'll ping them on IRC to make sure it lands on production this week.
Flags: needinfo?(jyeh)
Hi Joseph,
Any update?
Flags: needinfo?(jyeh)
As mentioned in https://bugzilla.mozilla.org/show_bug.cgi?id=1254420#c3 , the production server will not be update until March 29. If QA need to test anything, please check it on the dev server. Thanks.
Flags: needinfo?(jyeh)
Comment on attachment 8732048 [details] [review]
[gaia] jostw:josyeh/Marketplace/master/Bug1250404 > mozilla-b2g:master

Hi Rex, this patch simply just replace the icon of Web Apps with the updated version. Since the production server did not update yet, I replace the icon manually.

Please take a look, thanks!
Attachment #8732048 - Flags: review?(rexboy)
Attachment #8732048 - Flags: review?(rexboy) → review+
Landed in gaia master.

https://github.com/mozilla-b2g/gaia/commit/e5098978adae8750f013d96a825820f75b4054ac
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8732048 [details] [review]
[gaia] jostw:josyeh/Marketplace/master/Bug1250404 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1250404
[User impact] if declined: No new Web Apps icon 
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: No
Attachment #8732048 - Flags: approval-gaia-v2.5?(jocheng)
Comment on attachment 8732048 [details] [review]
[gaia] jostw:josyeh/Marketplace/master/Bug1250404 > mozilla-b2g:master

Approve for TV 2.5
Attachment #8732048 - Flags: approval-gaia-v2.5?(jocheng) → approval-gaia-v2.5+
You need to log in before you can comment on or make changes to this bug.