"Assertion failure: aContainer (Must have parent here)" with createShadowRoot

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
3 years ago
4 months ago

People

(Reporter: jruderman, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 2 bugs, {assertion, testcase})

Trunk
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox-esr52 wontfix, firefox56 wontfix, firefox57 wontfix, firefox58 wontfix, firefox59 ?)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8722847 [details]
testcase

Assertion failure: aContainer (Must have parent here), at layout/base/nsCSSFrameConstructor.cpp:4857
(Reporter)

Comment 1

3 years ago
Created attachment 8722848 [details]
stack
William, what do you think?
Flags: needinfo?(wchen)
Whiteboard: btpp-followup-2016-03-03
Whiteboard: btpp-followup-2016-03-03 → btpp-followup-2016-03-10
William will look at this after his patches for the new Shadow DOM API land.
Depends on: 1205323
Flags: needinfo?(wchen)
Tested with the webcomponents pref enabled and Stylo disabled.

Fix range:
INFO: First good revision: 08cec1c29418b33a27fc254c884494fb5cced0dd
INFO: Last bad revision: 846d96d2edb40886b016b3d1a478c3a7389c9c4d
INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=846d96d2edb40886b016b3d1a478c3a7389c9c4d&tochange=08cec1c29418b33a27fc254c884494fb5cced0dd

Fixed by bug 1331322. NI myself to land the test.
Assignee: nobody → bobbyholley
Status: NEW → RESOLVED
Has Regression Range: --- → no
Last Resolved: 10 months ago
status-firefox47: affected → ---
status-firefox-esr52: --- → wontfix
Depends on: 1331322
Flags: needinfo?(ryanvm)
Flags: in-testsuite?
Resolution: --- → FIXED
Whiteboard: btpp-followup-2016-03-10
Target Milestone: --- → mozilla54
Flags: needinfo?(ryanvm)
Flags: in-testsuite?
Flags: in-testsuite+
Backed out for failing own crashtest: 

https://hg.mozilla.org/integration/autoland/rev/07c86adc1b5f6775a37f4f1686c81426112c1a04

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=10ec88e1aa4e737f61b8199a34327bd8be4a1a76&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=usercancel&filter-resultStatus=runnable&filter-resultStatus=retry
Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=138487175&repo=autoland

Assertion failure: content->GetFlattenedTreeParentNodeForStyle() == &aContent, at z:/build/build/src/layout/base/ServoRestyleManager.cpp:1220
Assertion failure: !pd->minidump, at z:/build/build/src/toolkit/crashreporter/nsExceptionHandler.cpp:3430
TEST-UNEXPECTED-FAIL | file:///Z:/task_1508505456/build/tests/reftest/tests/layout/base/crashtests/1250793.html | application terminated with exit code 1
REFTEST PROCESS-CRASH | file:///Z:/task_1508505456/build/tests/reftest/tests/layout/base/crashtests/1250793.html | application crashed [@ mozilla::VerifyFlatTree]
REFTEST PROCESS-CRASH | file:///Z:/task_1508505456/build/tests/reftest/tests/layout/base/crashtests/1250793.html | application crashed [@ mozilla::VerifyFlatTree]
REFTEST PROCESS-CRASH | file:///Z:/task_1508505456/build/tests/reftest/tests/layout/base/crashtests/1250793.html | application crashed [@ CrashReporter::OnChildProcessDumpRequested]
Flags: needinfo?(ryanvm)
Well that's disappointing.
Assignee: bobbyholley → nobody
Status: RESOLVED → REOPENED
status-firefox56: --- → wontfix
status-firefox57: --- → wontfix
status-firefox58: --- → fix-optional
Flags: needinfo?(ryanvm)
Flags: in-testsuite?
Flags: in-testsuite+
Resolution: FIXED → ---
Target Milestone: mozilla54 → ---
Never ceases to amaze me too - I did 50 crashtest runs across every platform on Try before pushing this and didn't see this happen once.
Hah, that's because Emilio added that assert yesterday in bug 1409088!
Flags: needinfo?(emilio)
Well, glad it's catching bugs :)

This bug is because HTMLVideoElement also contains an XBL binding, I think, so we mess up the flattened tree somehow... probably we should just ban shadow root in HTMLVideoElement, or something like that...
Flags: needinfo?(emilio)
2 failures in 735 pushes (0.003 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 2

Platform breakdown:
* windows10-64: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1250793&startday=2018-01-29&endday=2018-02-04&tree=all
AttachShadow doesn't support <video>, and createShadowRoot is gone from the spec.
Status: REOPENED → RESOLVED
Last Resolved: 10 months ago4 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.