[config] Add virginmedia.com | ntlworld.com | blueyonder.co.uk | virgin.net [uk]

RESOLVED FIXED

Status

Webtools
ISPDB Database Entries
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: chief_uk_2613, Assigned: asuth)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

2 years ago
Created attachment 8722963 [details]
virginmedia.com.xml

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160210153822

Steps to reproduce:

virginmedia.com is not in the ISPDB please add virginmedia.com.xml file attached.
(Reporter)

Comment 1

2 years ago
Documentation: (Official Settings)

http://help.virginmedia.com/system/web/custom/viewArticle.jsp?uuid=D78BA863-ACDB-47E4-908B-28214405408B 
Email settings for addresses ending in @virginmedia.com

http://help.virginmedia.com/system/web/custom/viewArticle.jsp?uuid=68845FEE-4C8F-49D0-B169-AB9C60AE6915 
Using Thunderbird with Virgin Media Mail
(Reporter)

Comment 2

2 years ago
Created attachment 8722968 [details]
ntlworld.com.xml

Documentation: (Official Settings)

http://help.virginmedia.com/system/web/custom/viewArticle.jsp?uuid=C30B1D91-FA00-48EE-928A-A77F7C7D1EFA
Email settings for addresses ending in @ntlworld.com

http://help.virginmedia.com/system/web/custom/viewArticle.jsp?uuid=68845FEE-4C8F-49D0-B169-AB9C60AE6915 
Using Thunderbird with Virgin Media Mail
(Reporter)

Comment 3

2 years ago
Created attachment 8722969 [details]
blueyonder.co.uk.xml

Documentation: (Official Settings)

http://help.virginmedia.com/system/web/custom/viewArticle.jsp?uuid=55BDAE35-DD97-4F7C-A013-0BC0D6D21002
Email settings for addresses ending in @blueyonder.co.uk

http://help.virginmedia.com/system/web/custom/viewArticle.jsp?uuid=68845FEE-4C8F-49D0-B169-AB9C60AE6915 
Using Thunderbird with Virgin Media Mail
(Reporter)

Comment 4

2 years ago
Created attachment 8722970 [details]
virgin.net.xml

Documentation: (Official Settings)

http://help.virginmedia.com/system/web/custom/viewArticle.jsp?uuid=E7AFC426-B082-4C9E-AAFE-BD8B22824263
Email settings for addresses ending in @virgin.net

http://help.virginmedia.com/system/web/custom/viewArticle.jsp?uuid=68845FEE-4C8F-49D0-B169-AB9C60AE6915 
Using Thunderbird with Virgin Media Mail
(Reporter)

Updated

2 years ago
Summary: [config] Add virginmedia.com [uk] → [config] Add virginmedia.com | ntlworld.com | blueyonder.co.uk | virgin.net [uk]
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1176624
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1250865
(Reporter)

Comment 7

2 years ago

IDEA for Config file with virginmedia and yahoo example (see pastebin links below)
[*] http://pastebin.com/LMTjXBPZ
[*] http://pastebin.com/FfeZEYzd 
additionalSettings = optional

NOTE: Non-standard config files see pastebin links use attached files only.
(Assignee)

Updated

2 years ago
Duplicate of this bug: 769964
(Assignee)

Comment 9

2 years ago
(In reply to chief_uk_2613 from comment #7)
> IDEA for Config file with virginmedia and yahoo example (see pastebin links
> below)
> [*] http://pastebin.com/LMTjXBPZ

Thanks for considering a way to unify this!  The format right now only supports one <emailProvider> per config file.  The multiple <domain> entries we use for Yahoo are really just for aliasing on the server.  The idea is that if multiple domains share the same configuration, then we only need one XML file in our database so there's only one file to edit.  (The server deployment step runs a script that then copies/symlinks the one file so it's exposed as all the provided domain names.)

In this case, it appears that the four servers share some implementation commonalities but are not the same servers.  However, this can still work because we do support an %EMAILDOMAIN% variable.

They all use the same MX servers:
- mx.tb.ukmail.iss.as9143.net
- mx.mnd.ukmail.iss.as9143.net

AS 9143 is owned by Ziggo (www.ziggo.com), a Dutch cable company/ISP.  According to Wikipedia, the commonality is that Liberty Global (https://en.wikipedia.org/wiki/Liberty_Global) bought Virgin Media in 2013 and Ziggo in 2014.

Each IMAP server has a distinct IP address and has valid SSL/TLS certificates only for that domain.

The question in my mind right now is whether we can just add an MX entry for as9143.net or whether we should explicitly enumerate the different domains.  Unfortunately the reverse DNS lookups for the IP range the servers live in do not return useful values, just things like host-62.254.26.223.not-set-yet.virginmedia.net.  I'm going to check my scan.io internet-DNS-scan databases now quickly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 10

2 years ago
I was unable to quickly figure out what other domains might be sharing the infrastructure.  I'm going to just explicitly enumerate the domains for the following reasons:
- we're only talking about 4 domains, not tens or hundreds
- The as9143.net relationship is not intuitive and the depth of the MX entry hierarchy suggests intent and ability to host many infrastructures.

I'll unify the files momentarily and commit.
Assignee: nobody → bugmail
Status: NEW → ASSIGNED
(Assignee)

Comment 11

2 years ago
I've unified the four configuration files you provided under virginmedia.com using %EMAILDOMAIN%.  They should show up on the servers within about 30 minutes at https://live.mozillamessaging.com/autoconfig/v1.1/virginmedia.com and so forth.  If you want to double-check the configuration files and/or test with them, that would be fantastic.

Thanks very much for your assistance and persistence in getting these entries added!  They would not have been added without you.

$ svn commit
Adding         virginmedia.com
Transmitting file data .
Committed revision 150224.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

2 years ago
Created attachment 8724914 [details]
virgin.net.xml

Problem with domain virgin.net


https://community.virginmedia.com/t5/Email-Cloud-and-webspace/autoconfig-settings-for-Thunderbird-have-been-added-to-the-ISPDB/td-p/3050382

Q: Does imap.virgin.net (from Mozilla ISPDB) work instead of imap4.virgin.net (from Virgin Media Site)?
A: only imap4.virgin.net works.  imap.virgin.net does not resolve to a hostname.

Q: Does pop3.virgin.net (from Mozilla ISPDB) work instead of pop.virgin.net (from Virgin Media Site)?
A: Only pop.virgin.net will work
Attachment #8722970 - Attachment is obsolete: true
(Reporter)

Updated

2 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 13

2 years ago
Ugh, I'm sorry about missing those differences.  Because of the variety of permutations we're dealing with, I'm going to switch to just using the four different configuration files you provided, albeit making sure each emailProvider "id" matches the domain.
(Reporter)

Comment 14

2 years ago
you can use %EMAILDOMAIN% for virginmedia.com and ntlworld.com if needed
(Assignee)

Comment 15

2 years ago
Thanks for the follow-up and doing the analysis on that.  I think the trade-offs (confusion/complexity) are such that it makes sense to just use separate files for each of them.  I normalized virginmedia.com for whitespace reasons, but left the other files unchanged except for the id's as noted.

$ svn commit
Adding         blueyonder.co.uk
Adding         ntlworld.com
Adding         virgin.net
Sending        virginmedia.com
Transmitting file data ....
Committed revision 150301.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.