Closed Bug 1250870 Opened 5 years ago Closed 4 years ago

Windows 10 complains "An app default was reset" when the default browser switches between Firefox and Nightly

Categories

(Firefox :: Shell Integration, defect)

Unspecified
Windows 10
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1324617

People

(Reporter: emk, Unassigned)

References

Details

Steps to reproduce:
1. Make sure KB3135173 is installed.
2. Install the release version of Firefox.
3. Install Nightly.
4. Options-General-Make default on Firefox.
5. Options-General-Make default on Nightly.

Actual result:
Toast will popup that says "An app default was reset".

Expected result:
No message should popup.

The reason is probably because Firefox and Nightly share the same ProgIds (FirefoxHTML and FirefoxURL).
Bug 918253 will fix this.
Depends on: 918253
Another STR:
1. Make sure KB3135173 (or Anniversary Update) is installed.
2. Install the release version of Firefox.
3. Options-General-Make default on Firefox.
4. Install Nightly.
Now Windows 10 *silently* takes over the default browser!
Duping forward because the new bug got more attention.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1324617
You need to log in before you can comment on or make changes to this bug.